Go Down

Topic: Womart TFT LCD Shield + Touch Panel Display (Read 25472 times) previous topic - next topic


I recently purchased in womarts a two-boards "TFT LCD Shield + Touch Panel Display"


and not get it to work, I have only a black screen. I'm using the sketch demo UTFT_Demo_320x240 from library UTFT.
Has anyone managed to run this?


There is another thread here that has a video linked that shows the solution.  You simply need to change the line:

UTFT myGLCD(ITDB24E_16,38,39,40,41);   // Remember to change the model parameter to suit your display module!

to :UTFT myGLCD(ITDB32S,38,39,40,41);   // Remember to change the model parameter to suit your display module!

Notice the difference in the areas I have colored in?  I have the sainsmart version of this screen and this fixed it for me.

Hope this helps



For a moment I thought I had found the solution in this forum and on the website of Henning Karlsen, but still does not work.
I even followed the instructions of Womarts and tried with the ITDB02_Graph16 reccomended. This library and examples are and obsolete and outdated, but also recommended by Womarts.

Still not working. I even downloaded the data sheets of the HY-TFT320 tft screen to follow the signals from the Arduino Mega 2560. First thing is to choose the type "2" in UTFT header "# define ITDB32S", choosing library SSD1289 16 bits.
See attached image.

However, could you tell me where I can see the video explaining? It came not attached.

I'm starting to doubt that this device has a manufacturing fault.


I got the same files as you did with my SainSmart version of this LCD.  I didnt link the video and the author does not speak durring the video he just deleted some characters and retyped them.  THe lines I listed in my last post here will fix your issue.  This line is in the beginning of the program.  Just make the changes I have listed and try it again.  The guy that developed the  ITDB02_Graph16 software told me that he no longer supports this as it is over a year old.  I can understan no longer developing on the old tech but making the old files still available would be nice. 



Hi alfelipe,
did you manage to run your device ?
because I've just received mine from womarts and I have the same problem  :~


Mar 09, 2013, 11:21 pm Last Edit: Mar 09, 2013, 11:44 pm by alfelipe Reason: 1
HI. Just I solved my problem and just access the forum to communicate it. If the TFT device is in black absolute and there is not even a gray image background, you should adjust the potentiometer in the adapter shield. I recommend you check this: just in the pin opposite to the pin marked as "JP2" on the TFT shield, if there is no a voltage slightly above 2.5 volts no light whatsoever, you will get a black screen. You must adjust the potentiometer even without running softare, until the TFT reach a light gray background. Turns clockwise increase the voltage. The reference is about 2.6 volts in the pin marked in the photograpy. Try it and see how it works. The potentiometer is like a brightness control but with a very critical threshold. I was tracing signals with oscilloscope this afternoon looking for the failure. I bought a second pair of TFT and ADAPTER shields in Womarts and for this reason I knows the problem was located in the adapter shield.  Very simple? I must be an idiot for not having tried to adjust the potentiometer first before buying another pair of shields. :-)
More simple: if you get a blank (no gray) screen, turn clockwise the potentiometer, without running software, until you reach a light gray background. ;-)
Sorry, but I don'n know how upload the photo in this post. You can see it in http://www.sepca-sctfe.org/downloads/arduino.jpg


Thanks for your reply. In fact, I had a totally black screen so I asked to Womarts and they told me to adjust the potentiometer 15 rounds counterclockwise. I already tried it and I checked with my multimeter but there was nothing on the pin 19. I checked on the arduino and there was 0 volt on the pin 3.3 volts. So I have a problem with the arduino :( I explained the problem to Womarts and they send me another one :p
I borrowed another mega to a friend and all works fine with the UTFT and Utouch librairies...


I struggled with a SainSmart 3.2 LCD and adapter card and then realized I had the libraries and examples in the wrong folders as well as the wrong model number. Using Sain Smart download (link below) or Henning's code I had the same problems - because I was making the same mistakes. Here was my solution:

So, the new auto import puts libraries where they need to be. Using IDE Arduino 1.5.2 you can import the zip file ( Sketch|> Import Library|> Add Library...) the  32lcd.zip file from Sain Smart document needs to be renamed because it starts with a number  so rename the zip to something like SS32lcd.zip. The automatic import of arduino 1.5.2 IDE will put the UTFT library files in the right place. You will still need to copy the example folder over to the example folder in the ....\arduino-1.5.2 IDE installed folder for them to show up in the File|>Examples|>  menu.  You can save your changes into your sketchbook and your customization will be preserved there.

http://www.sainsmart.com/sainsmart-3-2-tft-lcd-display-touch-panel-pcb-adapter-sd-slot-for-arduino-2560.html [font=Verdana]download link 2[/font]

then change the line:

UTFT myGLCD(ITDB24E_16,38,39,40,41);   // Remember to change the model parameter to suit your display module!
to the SSD1289 model for the Sain Smart unit

UTFT myGLCD(SSD1289,38,39,40,41);   // Remember to change the model parameter to suit your display module!
  resave this modified file to your sketchbook using File|>SaveAs

now the example UTFT_Demo_320x240.ino works!


The IDE must be closed and restarted to see the new libraries and the Example files

Once you see how the auto library import install sets up the folders using the zip file you could use  Henning's rar files extracted and moved to the same places - I haven't figured how to get the arduino import to accept a RAR file

Once you get all the linked libraries installed in the right folders you can open sketches from other locations BUT if the linked libraries have changes the IDE will still see the old versions you put in using the import feature.

Libraries in the wrong place will throw less than helpful compiler errors like : 'UTFT' does not name a type

Libraries with the same names in different folders could lead to using a different library than the one you have just downloaded or are expecting or the one you just modified but is in a different folder- be careful to watch directory structure and use new names

"Arduino Cookbook" by O'Reilly has some simple explanation of Libraries and directory structure CH 16 starting page 561


me too,I've just received mine from womarts and I have the same problem   


If your problem is a black display, the solution is in reply #5. Many lucky.


Got mine some days ago and I had the same problem, had to change the display type to "ITDB32" (note that there's no 'S'), it wouldnt work with the S.

I'm using the UTFT lib.

Now, I'm struggling with the SDCARD option, had to swap to pins on the shield for it to be reconized, now it initialize the card but cant read it...

To be continued...


I recently purchased a Womart's 2.4" TFTLCD & Touch Panel.  Mine is a one board shield thar plugs directly into my Funduino Uno R3.

The screen lights immediately on plug in. 

I have downloaded the libraries recommended by Womart.

When I try to compile and execute the graphicstest example I get an erroe on this line:

            "TFTLCD tft(LCD_CS, LCD_CD, LCD_WR, LCD_RD, LCD_RESET);"

            The error is:

                                 no matching function for call to "TFTLCD::TFTLCD(CONST UINT8_T&, CONST UINT8_T&, CONST UINT8_T&, CONST UINT8_T&, CONST UINT8_T)"

I get this under Arduino Software V. 1.0.4 & 1.0.5.

I have tried the  UTFT and UTouch libraries.

Under both ARM & AVR Menus I get Sketch too big for UTFT_Demo_320x240.

I get the same error for UTouch_ButtonTest.

In both cases I change the slash so it knows I am use Uno R3.  I also change to the model parameters to ITDB32 as indicated earlier in this forum.

Any Chance I can get some help with this?



I got my TFTLCD from Womart working.   :)

I downloaded and ran Arduino 0023  with the TFTLCD library added to the libraries folder.  I loaded and successfully tested both examples provided in the download recommended by Womart.

I proved the screen and touchscreen works.  Now, I have to prove how good a programmer I am and port the examples to Arduino 1.0.4 or 1.0.5.  Then I get UTFT and UTouch libraries working.

More to com later! :)


hi all, I just bought one of these tft lcds. but I cant find any part number or anything that tells me what kind it is. all I know is that its a 2.4" tf with touch and sd .
they sent me a zip that included 2 examples and a library. none of the examples work. it gives me an error on the line that defines a new tftlcd object.
can anyone help me? I read what everyone have said but none applies to me.
and by the way, when I connect it to my arduino it turns on and gives me a blank white screen.
thank guys.


As I posted earlier,  I downloaded Arduino 0023. 

I put TFTLCD library in the library folder, loaded and ran both examples.  They worked.

I am now experimenting with UTFT library.  Because of the reaction I am getting from the LCD screen when I try different numbers for the pins in the myGLCD command, I suspect a pin number problem.

Good Luck

Go Up