Pages: [1]   Go Down
Author Topic: Servo rattert nach einschalten der Stromversorgung  (Read 783 times)
0 Members and 1 Guest are viewing this topic.
Germany
Offline Offline
Jr. Member
**
Karma: 1
Posts: 87
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Habe einen günstigen 9g mini Servo. Immer wenn ich die Stromversorgung einschalte dann knattert er leicht für ca 6-10 Sekunden, so als ob er sich justieren würde.  Ist das normal oder kann ich das Unterbinden?
Logged

Bavaria
Offline Offline
Newbie
*
Karma: 3
Posts: 39
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi!

Wie versorgst du das Teil. Hört sich nach zu wenig Strom an...

ulli.
Logged

Germany
Offline Offline
Jr. Member
**
Karma: 1
Posts: 87
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Zuerst mit 4.5 und nun mit 6v. Jetzt bewegt er sich auch ein wenig beim anschließen der Stromversorgung. Woran liegt das?
Könnte es vielleicht sein das ich ihn vor dem ausschalten in 0 Position bringen muss? Wie mache ich das am besten?
Logged

Bavaria
Offline Offline
Newbie
*
Karma: 3
Posts: 39
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo!

Die Frage war nicht nach der Spannung, sondern nach der Stromstärke ((Milli-)Ampere).
Wie hast du die Stromversorgung des Servos gelöst? Woher bekommt der Servo den Strom?

ulli.
Logged

Germany
Offline Offline
Jr. Member
**
Karma: 1
Posts: 87
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

4 x 1,5v Mono Batterien, dass sollte genug Power haben smiley Vorher waren es 3 x 1,5v Mono.
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 78
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi, Servos brauchen eine Betriebsspannung von 6 Volt. mit 4.5 laufen die nicht. HighVoltage Servos brauchen sogar 7.2 Volt.
Logged

Bavaria
Offline Offline
Newbie
*
Karma: 3
Posts: 39
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Schau mal ins Datenblatt des Servos, welche Spannung es braucht. Die Stromstärke sollte reichen  smiley-wink
Ist die Masse der Stromversorgung mit Masse des Arduino verbunden?
Passiert das Rattern auch, wenn du nur die Stromversorgung ran machst?
Lässt sich das Servo ansonsten ansteuern bzw. tut es (in etwa) das, was es soll?
Logged

0
Offline Offline
Edison Member
*
Karma: 20
Posts: 1980
Wo ein Wille ist, da ist auch ein Weg !
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Servos brummen aber auch wenn man Sie bis zum Anschlag steuert.
Logged

Mein Arduino Projekte Blog:
http://ardu-megatank.blogspot.de/

Germany
Offline Offline
Jr. Member
**
Karma: 1
Posts: 87
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Servo benötigt 4,6 - 6v, Masse ist verbunden.
Wie gesagt, der Servo rattert (bzw. bewegt sich leicht) nur nach dem Anschließen der Versorgungsspannung. Nach ein paar Sekunden hört das auf.
Ich kann den Servo dann normal ansteuern und er macht was er soll.
Code:
servo.write(180);
delay(2000);
servo.write(90);         
delay(2000);
servo.write(180);
delay(2000);
servo.write(90);   
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hatte ähnliches problem und habe es gelöst in dem ich im setup teil die servo auf 0 "fahren" lasse.
Weiß zwar nicht ob das die eleganteste Lösung ist, aber seit dem ist ruhe beim anschließen der stromquelle und zum start soll sie bei mir eh auf 0 sein.
Logged

Pages: [1]   Go Up
Jump to: