Pages: [1]   Go Down
Author Topic: Can't unpload to Mini Pro  (Read 215 times)
0 Members and 1 Guest are viewing this topic.
Amsterdam
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi all,

Used Nick Gammon's chip programmer with the UNO-R3 as ISP to burn bootloader on Pro Mini (with ATmega 328P); worked fine result ok.

But can't upload sketch to Pro Mini through USB2SERIAL (worked before burning bootloader and still works with other Pro Mini) and I get the comment:

avrdude: stk500_getsync(): not in sync: resp=0x00

Can anyone tell me what this means? What can I do to make it work again?
Logged

Sydney, Australia
Offline Offline
Edison Member
*
Karma: 33
Posts: 1250
Big things come in large packages
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

The basic issue is that there is no automatic reset of the Mini Pro when the serial line becomes active.

Here is the process that I use:
1. Start the compile/download cycle
2. At some point the 'Rx' LED on the MiniPro will flash.
3. Press the reset button when this happens.
4. The bootloader will take over on reset and allow the download to be executed.

It can be a bit tricky, but like most of these things the timing will comm with practice smiley

An alternative is to modify the Pro Mini woith a capacitor (from memory) that reset the serial line. You can search for this using google.
 
Logged

Arduino libraries http://arduinocode.codeplex.com
Parola hardware & library http://parola.codeplex.com

Pages: [1]   Go Up
Jump to: