Go Down

Topic: attiny bootloader not compiling (Read 570 times) previous topic - next topic

Drc3p0

I am trying to get a simple blink sketch to work on the attiny85 to make sure that the ISP and everything is working properly
Here's the reference i'm using for the wiring:
http://hlt.media.mit.edu/?p=1229

I am using an UNO.
I uploaded the arduinoISP code attached in this message that was provided by Coding Badly
I selected the Attiny85 @ 8Mhz

When i tried to burn the bootloader, this is the error message that popped up. 

Code: [Select]
/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf -v -v -v -v -pattiny85 -cstk500v1 -P/dev/tty.usbmodemfd131 -b19200 -e -Uefuse:w:0xFF:m -Uhfuse:w:0xD7:m -Ulfuse:w:0xE2:m

avrdude: Version 5.11, compiled on Sep  2 2011 at 18:52:52
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/Users/Darcyneal/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/tty.usbmodemfd131
         Using Programmer              : stk500v1
         Overriding Baud Rate          : 19200
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv: . [15]
avrdude: stk500_getsync(): not in sync: resp=0x15

avrdude done.  Thank you.


any idea what's going wrong?  thank you

magagna

1. Open Arduino IDE. Open File | Examples | ArduinoISP.
2. Upload this sketch to you Uno.
3. Click Tools | Programmer | Arduino as ISP
4. Change board type in Tools |  Board | ATTiny85 (internal 8 Mhz clock)
5. Click Tools | Burn Bootloader
6. You can now upload your code through the Uno via File | Upload using Programmer

If you're already doing all of this, confirm your connections from the Uno to the ATTiny85:

1. +5V on Uno to VCC on chip
2. Ground on Uno to ground on chip
3. Pin 10 on Uno to pin 1 on ATTiny85 (reset)
4. Pin 11 on Uno to pin 5 on ATTiny85 (MOSI)
5. Pin 12 on Uno to pin 6 on ATTiny85 (MISO)
6. Pin 13 on Uno to pin 7 on ATTIny85 (SCK)

Good luck!
http://en.wiktionary.org/wiki/magagna <-- My last name.  Pretty apt.

Coding Badly

1. Open Arduino IDE. Open File | Examples | ArduinoISP.


The version that comes with the IDE does not always work on Linux / Mac computers (the /Applications/Arduino.app directory is a good indication that @Drc3p0 has a Mac).

Code: [Select]
avrdude: Recv: . [15]
avrdude: stk500_getsync(): not in sync: resp=0x15


Huh.  That's a symptom I've never seen.  @Drc3p0, you sure have a knack for getting entangled with strange problems.

I suspect the Uno bootloader is responding instead of the ArduinoISP sketch.  Make certain...

• The disable-auto-reset capacitor is put in place after uploading the modified ArduinoISP sketch

• The disable-auto-reset capacitor is making good electrical contact if, like me, you connect it directly to your Uno

Erni

Drc3p0
I just tried the ISP  sketch you provided, and got the same error.
I am using Windows Vista, and Arduino 1.01

I tried the blink sketch

Code: [Select]

Binary sketch size: 756 bytes (of a 8.192 byte maximum)
D:\arduino-1.01\arduino-1.0.1-windows (1)\arduino-1.0.1\hardware/tools/avr/bin/avrdude -CD:\arduino-1.01\arduino-1.0.1-windows (1)\arduino-1.0.1\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -pattiny85 -cstk500v1 -P\\.\COM3 -b19200 -Uflash:w:C:\Users\EC\AppData\Local\Temp\build8922342308274663574.tmp\Blink.cpp.hex:i

avrdude: Version 5.11, compiled on Sep  2 2011 at 19:38:36
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "D:\arduino-1.01\arduino-1.0.1-windows (1)\arduino-1.0.1\hardware/tools/avr/etc/avrdude.conf"

         Using Port                    : \\.\COM3
         Using Programmer              : stk500v1
         Overriding Baud Rate          : 19200
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv: . [15]
avrdude: stk500_getsync(): not in sync: resp=0x15

avrdude done.  Thank you.


Erni

#4
Feb 09, 2013, 02:34 pm Last Edit: Feb 09, 2013, 03:08 pm by Erni Reason: 1
Next option was to try this modified ISP

http://arduino.cc/forum/index.php/topic,108797.msg824488.html#msg824488   reply #39.

It worked without errors, so I believe there is an error in your ISP sketch, or shouldn't it work on a MAC ?

Coding Badly

...or shouldn't it work on a MAC ?


It's an earlier attempt to get past a Linux / Mac related bug in ArduinoISP.  The sketch in reply #39 is the latest (and apparently more successful) attempt.

Some details about the first attempt...
http://arduino.cc/forum/index.php/topic,88649.msg673678.html#msg673678

Drc3p0

#6
Feb 10, 2013, 06:43 am Last Edit: Feb 10, 2013, 06:45 am by Drc3p0 Reason: 1
I had instituted this file change based off of previous instructions.  Not sure if it could contribute to the issue at hand...  I am using arduino Uno version 1.0
http://arduino.cc/forum/index.php/topic,116674.msg881917.html#msg881917


The following is how to apply the fix for MacOSX. This is based of AVR crosspack 20090319.

Extract ld.zip. This should give you a single extensionless file "ld".

Right-Click on Arduino.app
Click "Show Package Contents"
Due to MacOSx inability to merge folders, you will have to navigate to the correct folder yourself:
/Contents/Resources/Java/hardware/tools/avr/avr/bin/

Copy and replace "ld" with the version from the zip archive.

The zip is attached to this post.
(Known to work on:
-Snow Leopard
- Mountain Lion
for other versions, please let me know if it works ok)

Coding Badly


That takes care of the linker problem.

Instead of the ArduinoISP sketch you are currently using, try the one @Erni suggested in his post...
http://arduino.cc/forum/index.php/topic,108797.msg824488.html#msg824488   reply #39.

Go Up