Pages: [1]   Go Down
Author Topic: Com1 not found error  (Read 607 times)
0 Members and 1 Guest are viewing this topic.
Luton,UK
Offline Offline
Newbie
*
Karma: 0
Posts: 9
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,
I have bought an arduino uno and trying to connect it to my computer by following the 'Getting Started' instructions. In instruction it say that to update the Arduino com from Port menu, but I can't find Ardunio COM1 in my port menu. I tried to upload the program to check if it is connected or not and it say Com1 not found. Please anyone help me with this.
Logged

Taimur

UK
Offline Offline
Shannon Member
****
Karma: 223
Posts: 12631
-
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

What operating system is your computer running?

Which version of the Arduino IDE are you running?
Logged

I only provide help via the forum - please do not contact me for private consultancy.

Poole, Dorset, UK
Offline Offline
Edison Member
*
Karma: 52
Posts: 2298
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Easy way - Unplug the Arduino, look at the list of com ports displayed by the IDE, now plug in the Arduino and check the list again. You should have a new/additional port displayed. Thats the one you want. Always works for me.

Mark
Logged

Luton,UK
Offline Offline
Newbie
*
Karma: 0
Posts: 9
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

My operating system is windows7 and arduino version is1.0.3 .
Logged

Taimur

Luton,UK
Offline Offline
Newbie
*
Karma: 0
Posts: 9
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have get it sorted now.

Thank You.
Logged

Taimur

Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

How did you do it? I have/had the same problem with my Dell notebook and Windows 7. Sometimes a reboot worked for me, but mostly it didn't.. I'm just curious^^
Logged

Luton,UK
Offline Offline
Newbie
*
Karma: 0
Posts: 9
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Go to Device Manager>Other devices>Unknown device. Click on unknown device and update the deriver software by selecting "ArduinoUNO.inf" (it should be in your downloaded Arduino files) and then check the Port(COM & LPT) in Device Manager, you should now see Arduino UNO R3 (COMxx).
After doing that, go into IDE tools select the right Serial Port i.e COMxx

Thats what I did.
Logged

Taimur

Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Oh! Thanks a lot! smiley
Logged

Pages: [1]   Go Up
Jump to: