Go Down

Topic: Colorduino HELP (Read 1 time) previous topic - next topic

vahakn

Hi thanks for the suggestions
i dont have a MEGA.
I have 2 UNOs and a LEONARDO.
surely one of them is supported.

any more help would be greatly appreciated

Vahakn

kd7eir

#4
Feb 12, 2013, 04:00 pm Last Edit: Feb 12, 2013, 04:04 pm by kd7eir Reason: 1
I used a Mega2560 to program my Colorduino, it also does not have a removable chip.

Maybe these steps will work with your Leonardo.

This is essentially a serial passthrough.  When you put the rx of the 2560 to the rx of the colorduino you are actually putting the tx of the the mega to the colorduinos rx, allowing you to upload using the regular arduino bootloader present on the colorduino, and by holding the reset you prevent the mega from responding allowing the colorduino to do so instead.

Again, not sure if this will work with a Leonardo as I do not have a Leonardo to test it with.

This is what I came up with that worked right away:

Mega2560           Colorduino
-----------------------
RX0 (pin 0)  ->>  RXD
TX0 (pin 1)  ->>  TXD
RESET         ->>  DTR
5V              ->>  VDD
GND           ->>  GND

Mega2560
Reset -> 4.7uF capacitor -> 5V

When I uploaded the sketch, as soon as the size of the sketch appeared in the window, I held down the RESET switch on the Mega2560 until the upload completed.

vahakn

#3
Feb 12, 2013, 02:29 pm Last Edit: Feb 14, 2013, 04:58 pm by vahakn Reason: 1
I was not aware I had to remove the chip from the Arduino.
I have an UNO.
I removed the chip and tried to upload and now I get this error when I try to upload: avrdude: stk500_getsync(): not in sync: resp=0x00


Do I leave the chip out all the time when I use the colorduino?

I have a Leonardo also, but the chip is not removable. Am I UNABLE to use this Arduino board?

Thanks for your response.

Vahakn

kd7eir

#2
Feb 09, 2013, 03:29 am Last Edit: Feb 09, 2013, 03:42 am by kd7eir Reason: 1
I think that you didn't upload the code into the colorduino… the R G B every one second is the factory code that comes by default. When you uploaded the code in the arduino software, did you saw the message "Upload Complete" ?

Remember to take out the ATmega microchip from the Arduino before you upload a new code into the colorduino.

Hope it helps

vahakn

hello

ive recently bought and set up a colorduino with a Leonardo.

Im installed the latest Lincomatic colorduino library, but i cant get the first plasma program to work.
My LED RGB matrixjust cycles from solid 100% R to G to B every second.

Does anyone have any experience with colorduino and knows what the problem is?
ive wired it correctly

RX to RXD
TX to TXD
RESET to DTR
VDD to 5v
GND to GND

HELP!

thanks

Vahakn

Go Up