Pages: [1]   Go Down
Author Topic: Programming a Mega2560 via BT  (Read 347 times)
0 Members and 1 Guest are viewing this topic.
Manchester
Offline Offline
Newbie
*
Karma: 0
Posts: 40
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

So I can program a Duemilanove just fine using an RN-42.  I've broken out the DTR pin and connected it via a cap.  Everything works fine.

I switched to a Mega 2560 and it just won't work.  First off I couldn't get it to auto reset, but though trial and error I fixed this by upping the cap to 10uF.

Not it auto resets just fine and appears to do something for a few seconds, but then just continues the old program and AVRdude hangs.

I've tried changing the BT device to 115.2kbps and 57.6kbps, neither work.

Any thoughts? I've run out of ideas.
Logged

Austin, TX
Offline Offline
Faraday Member
**
Karma: 64
Posts: 6055
Baldengineer
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Are you able to load the same code to the 2560 via USB?
Logged

Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

Rapa Nui
Offline Offline
Edison Member
*
Karma: 53
Posts: 1990
Pukao hats cleaning services
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

DTR/CTS/RTS signals do not work with BT modules. You need to set BT module according to:
http://arduino.cc/forum/index.php?topic=132179.0
It works fine with my UNO..

Logged

Manchester
Offline Offline
Newbie
*
Karma: 0
Posts: 40
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Are you able to load the same code to the 2560 via USB?

Yes if I swap the BT module for FTDI and leave everything else the same it works fine.
Logged

Manchester
Offline Offline
Newbie
*
Karma: 0
Posts: 40
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

DTR/CTS/RTS signals do not work with BT modules. You need to set BT module according to:
http://arduino.cc/forum/index.php?topic=132179.0
It works fine with my UNO..



As I said I've broken out the DTR pin from the BT module.  I can reprogram other Arduinos just fine, and I it's resetting the Mega 2560, but it's just not syncin up.
Logged

Manchester
Offline Offline
Newbie
*
Karma: 0
Posts: 40
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Does anyone have any suggestions, I don't know what else to try smiley-sad
Logged

Pages: [1]   Go Up
Jump to: