Pages: [1]   Go Down
Author Topic: Mac OS X Arduino USB serial port not appearing  (Read 2819 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

The serial ports don't show up , and when they do, they are not usable.

I am trying to run my RepRap through an Arduino Mega 2560. The Connection worked once. It was a fluke, just changed the USB slot on the side. The only connections that show up are:

/dev/tty/SerialPort (& cu instead of tty)
and
/dev/tty/Bluetooth-PDA-Sync

These don't work. The network settings are set with UBS modem (not configured)

Anybody know what to do to get the Serial port working on the Mac?
Logged

Manchester, NH
Offline Offline
Full Member
***
Karma: 0
Posts: 116
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I just had the same problem! Download 2.2.18 for Mac OSx from:

http://www.ftdichip.com/Drivers/VCP.htm

Install the FTDI driver. I then did a re-boot but that may not be necessary. Open the Arduino IDE, connect the Arduino, and in the Tools menu should now be a USB serial option (don't remember exactly what it's called). The USB serial option didn't appear unless the Arduino was connected.
Logged

Fort Lauderdale, FL
Offline Offline
Faraday Member
**
Karma: 71
Posts: 6144
Baldengineer
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I am trying to run my RepRap through an Arduino Mega 2560.
Is this an official board or something specific to the RepRap?  If it is specific, what is the USB to serial chip being used?

just changed the USB slot on the side.
On the side of what?

These don't work. The network settings are set with UBS modem (not configured)
What is a UBS modem?


Anybody know what to do to get the Serial port working on the Mac?
Plug the board in.
Logged

Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.c

Pages: [1]   Go Up
Jump to: