Go Down

Topic: TFT Display Verständnissproblem (SPI etc...) (Read 1 time) previous topic - next topic

Rene_Merten

Feb 08, 2013, 11:30 pm Last Edit: Feb 08, 2013, 11:36 pm by Rene_Merten Reason: 1
Hy,

versuch grad 2 Displays ans laufen zu bekommen. bei den einen, ist ein 1.8" SPI TFT Display, hab ich zwar die Libery, aber die Pinnbezeichnung aus den beispielen passt nicht. Display: HY-1.8TFT
Habe mosi und dc nicht. Meine Pinns sind folgende: Reset, A0, SDA, SCK, CS.....

So stehts im beispiel:
Code: [Select]

#include <Adafruit_GFX.h>   
#include <Adafruit_ST7735.h>
#include <SPI.h>

#define sclk 4
#define mosi 5
#define cs   6
#define dc   7
#define rst  8



Beim 2. Display handelt es sich um ein 2.4" Touch TFT. HY-TFT240_262K
Bei den ganzen anschlussbeispielen werden Displays gezeigt mit 40 Pinns. Ich hab nur 20, und somit die Datenleitungen DB8-DB15 garnicht. Aussehen tut es wie meins, aber die Pinnbelegung ist von ein anderes.

Hier mal ein Link dazu: http://www.geeetech.com/wiki/index.php/2.4%22TFT_LCD


uwefed

1. Display

Code: [Select]
#define sclk 4     //SCK
#define mosi 5    //SDA
#define cs   6      //CS
#define dc   7     //A0
#define rst  8      //Reset


2. Display:
Wo hast Du's her?

Grüße Uwe




Rene_Merten

#2
Feb 08, 2013, 11:40 pm Last Edit: Feb 08, 2013, 11:44 pm by Rene_Merten Reason: 1
Vom freundlichen ALI :)
http://www.aliexpress.com/item/2-4-240-320-262K-TFT-LCD-color-touch-Screen-Module-support-SD-card-STM-51/566130069.html

Aber das es ein SPI ist, bezweifel ich, warum habe ich sonst D0-D7. IC"s sind 2 x 74HC2450

LG. Rene

uwefed

#3
Feb 08, 2013, 11:50 pm Last Edit: Feb 11, 2013, 10:32 pm by uwefed Reason: 1
Wieso kaufst Du Elektronikteile wo es kein Datenblatt oder sonstige vollständige Beschreibung gibt? Hast Du den Händler angeschrieben und um ein Datasheet gefragt?
Grüße Uwe

Rene_Merten

Supi, erste geht schon mal. Sehr eindrücksvoll die Displaydemo. Datenblatt fürs 2. hab ich, aber eben in der 40 Pin Version, was mit meinem nicht übereinstimmt. Hab ja nur 20. Pinnbelegung Steht auf Platine, aber auch wieder anders als beim 1. Display.

Gand -OK
VCC -OK
NC -OK
RS
RW
RD
DBO-DB7 -OK
CS -OK
NC -OK
RST -OK
NC -OK

Dann hab ich noch 2 andere Leisten, die sind fürs Touch und SD Card, was mich momentan noch garnicht benötige.

Rene_Merten

Das 2. TFT Display bekomm ich nicht ans laufen. Egal was ich probiere, es geht will nicht. Habe mir diese Seite mal angesehen, und auch ausprobiert, es will einfach nix anzeigen. http://arduino.cc/forum/index.php?topic=37960.0

LG. Rene

Go Up
 

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.
Name:
Email:

shortcuts: alt+s submit/post or alt+p preview