Go Down

Topic: Online IP wtih Ethernet Shield [Solved] (Read 2 times) previous topic - next topic

Darwoon

I activate DMZ for the board on my router


If that is the case, you need to port forward a port on the router WAN interface to the localnet ip of the Arduino.

Sorry, but I didn't understand what you said :) english is not my fisrt language.

SurferTim

#16
Feb 25, 2013, 09:59 pm Last Edit: Feb 25, 2013, 10:08 pm by SurferTim Reason: 1
You are doing fine! :) If your arduino is in the DMZ, then you should be able to access it from the internet, considering your ISP isn't blocking you.

If I can't use port 80, then I like using port 8088. It will normally get by an ISP block if they block port 80. Can you give that a try?

edit: Insure if the arduino is a server, use a web browser to connect. Use the public ip with the port appended
http://x.x.x.x:8088

Darwoon

it still doesn't work  :~
Maybe it is my ISP which blocks the connection. The default HTTP port 80 works on my client application. If I use an other port like 8088 or 5550, an error occur "Connection refused".
With port 80, the client manage to connect to the Arduino server, but Arduino doesn't see there is a new client. it's really strange  8)


SurferTim

#18
Feb 25, 2013, 10:40 pm Last Edit: Feb 25, 2013, 11:22 pm by SurferTim Reason: 1
"Connection refused" is a firewall response. Are you saying you can connect using port 80 if you assign port 80 to the Arduino, just no response? If so, then you are there! The code you posted above does not do anything. That is exactly what it should do if there is a connection. Nothing.

Here is a server sketch. I know it works. I tested it.
http://playground.arduino.cc/Code/WebServerST

edit: I went over everything, and this would cause a problem with non-localnet clients.
Code: [Select]
  Ethernet.begin(mac, ip, gateway, subnet);
It should be
Code: [Select]
  Ethernet.begin(mac, ip, gateway, gateway, subnet);

Darwoon

#19
Feb 25, 2013, 11:55 pm Last Edit: Feb 25, 2013, 11:58 pm by Darwoon Reason: 1

It should be
Code: [Select]
 Ethernet.begin(mac, ip, gateway, gateway, subnet);

Yes I already change my code with the server sketch you posted above. But it doesn't change anything...

I tried to launch the client apps from windows (port 5550)... The error returned is "No error"  :smiley-mr-green: So, it shows that on linux it's a firewall issue.
It must be the router configuration though.

SurferTim

Do you have a commercial/business account with your Internet Service Provider? My provider does not look kindly on those trying to "borrow" services they are not paying for.

My advantage is: I have several computers on the internet, most on separate static ips, all on commercial accounts. If I have a problem, I do not hesitate calling my ISP and asking about it.

Darwoon

I have a private account with my ISP. And I had had the same probleme before, when I made a minecraft server on my computer. The problem was port opening and forwarding... it worked half the time  =(

But recently, I made an online tchat (server in C, client in PhP), and it works fine with a personnal port... I'll try to use my tchat with the port 5550 tomorrow

SurferTim

That sounds like a good test. Most ISPs don't care if you have one device off-port sending data to your residential ip. They just don't want you hosting a public website without fair compensation.

Darwoon

OMG ! I found the problem this morning... I believe I'm gonna commit the suicide...
My ISP port forwarding works well... but not if I'm connecting FROM my ISP ! I sent the client apps to a friend, and it works perfectly... Two weeks ago I got the second version of my isp box. The first version worked well, but I read on the internet that there are many problems with the second...

I thank you so much for your help  :)

ps : my tchat doesn't work anymore with my new ips box, and it have been worked with the same code... just because they fucked the port forwarding !  =(

sonnyyu

Quote
my tchat doesn't work anymore with my new ips box, and it have been worked with the same code... just because they fucked the port forwarding



few ways might help;-

plan A.

change TCP port number, if TCP port 22 is not used, then use it, most ISP use it to manage itself equipment,  some time might be 2222.  Use UDP port number above 10000.

plan B.

load  VPN client app into your router. setup VPN.

plan C.

SSH tunneling, load SSH tunneling into router.






Darwoon

Thanks sonnyyu, I'll try with port 22 / 2222  :) But I can't use a VPN or SSH tunnel connection with my actual IPS.

Quote
my tchat doesn't work anymore with my new ips box, and it have been worked with the same code... just because they fucked the port forwarding


But I meant, it doesn't work anymore with the same configuration as before. That's it, if I want to use my chat on my own computer, I can't unless using a local connection just for users in my network. I only have to edit my code to work with the new port forwarding configuration of my ISP (which is a big sh**  XD).


sonnyyu

#26
Feb 26, 2013, 06:49 pm Last Edit: Feb 26, 2013, 07:08 pm by sonnyyu Reason: 1
Quote
I believe I'm gonna commit the suicide


Don't do that, there are 1,354,040,000 persons in same boat with you.

Great Firewall of China, It block almost every thing, even VPN....

China Population: 1,354,040,000 December 31, 2012


Darwoon

Great  :smiley-mr-green:
But my problem is solved, I've no more reason to commit the suicide ^^ now I'm gonna kill my ISP instead  :P

Go Up