Go Down

Topic: problem with servo (Read 830 times) previous topic - next topic

zoomkat


Thanks; it worked with 6 volt :Ds. But why it was troubling with 9volts? I thought it have an internal pullup resistor in the circuit! :~


If "it" is the servo, most servos are rated for 4.8v-6v operation. Higher voltages may cause erratic operation or damage the servo.
Consider the daffodil. And while you're doing that, I'll be over here, looking through your stuff.   8)

dattasaurabh82

So initially when I was driving it from the board, it current was the limitation? hmm; got it now.

sanath

Hey , i am facing a similar problem , i have given a 5volts (stepped down from 12 volts ) to the board , the 9g servo runs properly but i have a 60g avionic servo , if i connect it in the same way and try ,the servo starts once and then stops , also can someone explain the improper rotation with these servos , i am really out of ideas and a bit frustrated .( i used the library , sweep sketch )

JimboZA

Sanath, I'm not sure from your description how you have it wired- do you have the servo getting power from Arduino or its own power as shown in zoomkat's picture?

My starting point for any servo "funnies" has become: give the servo its own power even if it's a small servo, and see if the problem goes away.
Roy from ITCrowd: Have you tried turning it off an on again?
I'm on LinkedIn: http://www.linkedin.com/in/jimbrownza

Go Up