But in regards to the rest of the post I am not using any delays im using millis().
Is any of that commented out code contributing to the slow reaction to the switch presses? I don't think so. So, get rid of it.
of the remaining
to its readability?
I don't think so, so use Tools + Auto Format to fix it.
The way I see it, the code is substituting calls to millis to determine when to do something for calls to delay to make the code wait. I don't see that the change makes things happen more often/faster. Of course the useless code and poor structure don't help.
int setVariableZero = 0;
Is this so that you can change to value to 27 at some point? Wouldn't you then to rename the variable to avoid looking stupid? How would that make maintenance any easier?