Go Down

Topic: Did I brick my arduino board ? (Read 444 times) previous topic - next topic

kerimil

I have arduino duemilanove 328P board. It worked fine for like 2 years, never had any issues with it or anything. I am using windows XP.

I uploaded arduino as ISP sketch and used it as a programmer - no problems whatsoever. Yesterday I accidetaly connected 12V to +5V pin and the ground of the power source to the ground on arduino - my breadboard circuit was a real mess - I guess I should have paid more attention.


Since that moment I can't even upload anything, all I get is ->
Quote
avrdude: stk500_getsync(): not in sync: resp=0x00
. When I reset the board the LED doesn't blink.

I bricked it didn't I ?



Now what can I do ?? Would buying a new Atmega328 chip with bootloader work ?
DId I f#ck up the uC IC itself or is it possible that some other components got forked up as well?
As far as I can tell the FTDI chip works as the RX LED does light up when I try to upload sketches, plus the power regulator seems to work fine too.



Krodal

#1
Feb 10, 2013, 04:06 pm Last Edit: Feb 10, 2013, 04:09 pm by Krodal Reason: 1
It's hard to say.
The FTDI chip correctly showing the leds, doesn't mean that the RX and TX path is still okay.

But if it happened to me, I would buy an ATmega328P and go for it.
Since you already have a programmer, let the Arduino IDE program a new bootloader into it.

You might have to write something on the board. Such things might cause problems later on. So if something weird happens in a year or two, you know it was the barbecued board.

If you only applied 12vdc to the +5 and ground pins, I would bet you fried the voltage regulator and associated components. If you try and replace the 328p and it does fix the problem, you may have to change the board to a duemilanove under tools. Remember when programming the board is powered by an already regulated 5vdc from the USB port (The regulator isn't directly used). One more thing, when powering the board and circuits with different voltages, ALWAYS connect all grounds, unless using a 1.5-5vdc relay thats controlling high voltage AC. Good luck!

kerimil

Well I guess I'll buy another arduino board and an Attiny chip. if I manage to revive my old arduino board I'll give the new one to my friend.


I feel kind of dumb for frying it - uhmm i guess it had to happen sooner or later
:smiley-mr-green:

Go Up