Pages: [1]   Go Down
Author Topic: pin-11 dysfunction  (Read 285 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i m using a arduino uno r3 .
the problem with my board is that no matter what output i send on the pin - 11 , it is giving a const output , somewhere between high and low . i tested it by connecting an LED to it . all the other pwm pins are working fine but not pin =11.
Is this a hardware problem or something is wrong with the comand .
please help me  smiley-sad
thanks  smiley-lol
Logged

Global Moderator
UK
Offline Offline
Brattain Member
*****
Karma: 290
Posts: 25834
I don't think you connected the grounds, Dave.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Please help us to help you.
Post code and observations.
Logged

"Pete, it's a fool looks for logic in the chambers of the human heart." Ulysses Everett McGill.
Do not send technical questions via personal messaging - they will be ignored.

0
Offline Offline
Shannon Member
****
Karma: 200
Posts: 11718
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Without more information (the complete sketch) its impossible to guess.
Logged

[ I won't respond to messages, use the forum please ]

Seattle, WA USA
Offline Offline
Brattain Member
*****
Karma: 601
Posts: 48543
Seattle, WA USA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
the problem with my board is that no matter what output i send on the pin - 11 , it is giving a const output , somewhere between high and low . i tested it by connecting an LED to it . all the other pwm pins are working fine but not pin =11.
How are you sending output on pin 11? What shields, if any, are attached?
Logged

Offline Offline
Edison Member
*
Karma: 9
Posts: 1016
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Is the pin high impedance while keeping the reset button pressed ?
Logged

Pages: [1]   Go Up
Jump to: