Go Down

Topic: ETHERNET shield...sans shield. (Read 428 times) previous topic - next topic

fred133084

Bonjour a tous,
j'aimerais connecter mon shield ethernet avec simplement des cables et non en l'emboitant sur ma carte mega.

j'ai donc branché les pin gnd et 5v.
puis les pin 4, et 10 à 13...



je tente d'acceder a mon shield via son ip mais cela ne marche pas.
(le shield emboité sur la carte fonctionne).

ai je oublié qqchose ?  (icsp ??)

thanks

AKkarol7

si j'ai bien compris tu veut plutot un ethernet shield... sans arduino?!  :smiley-eek:

fred133084

aie non je me suis mal exprimé !

en fait j'aimerai déporter mon shield au lieu de l'emboiter (empiler).
en gros j'aimerai le disposer juste a coté de ma carte arduino et non dessus.

AKkarol7

Genre tu voudrait par example que ton shield soit relier par un cable à l'arduino, de telle sorte qu'ils puissent être loing l'un de l'autre?
si oui j'imagine qu'il ny'a aucun probleme a ce que tu conecte des "cable jumper" mâle d'un coté et femelle de l'autre entre chacune des broche qui permettent la comunication entre l'arduino et son shild lorsqu'ils sont emboités.

fred133084

ben oui c'est ce que j'ai fait mais j'ai du oublié qqchose à mon avis...

j'ai bien le pin 4 10 11 12 13   vcc in gnd de reliés

(au fait c'est le shield ethernet arduino.)

skywodd

Bonjour,

L'ethernet shield n'utilise pas directement les broches 13, 12, 11, 10 pour le SPI mais le connecteur ICSP.
Si tu veut connecter ton ethernet shield sans l'emboiter il te faut câbler les alimentations (+5v et GND) de même que le port ICSP.
Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

fred133084

merci ! je me doutais bien que c'était un truc avec l icsp !
j'ai pas de connectique femelle pour tester je vais devoir attendre de les recevoir.

merci  :)

Go Up