Go Down

Topic: Arduino 2560 - usbmodem411 (Read 395 times) previous topic - next topic

thoa

Feb 11, 2013, 08:44 pm Last Edit: Feb 11, 2013, 09:09 pm by thoa Reason: 1
Hi there,
I´ve read your    
Please check the troubleshooting guide before posting here Guide, but my problems remain.

I have a ArduinoMega2560 R3 and I´m using MacOS 10.8.2. At the beginning there was no usbmodem or whatever (I´ve just had 2 red lights on my board).
So after checking my SystemProfile (my USB-port), I just found ATmega16u2 DFU.

t
Code: [Select]

brew installdfu-programmer
dfu-programmer atmega16u2 erase
dfu-programmer atmega16u2 flash Arduino-usbserial-atmega16u2-Mega2560-Rev3.hex
dfu-programmer atmega16u2 rese


Now I have a /dev/tty.usbmodem411 and a /dev/cu.usbmodem411.
Uploading something doesn´t work

Code: [Select]
vrdude: Version 5.11, compiled on Sep  2 2011 at 18:52:52
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/Users/tobias/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/cu.usbmodem411
         Using Programmer              : wiring
         Overriding Baud Rate          : 115200
avrdude: wiring_open(): releasing DTR/RTS
avrdude: wiring_open(): asserting DTR/RTS
avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer

It also doesn´t work with tty.usbmodem411

But now I don´t find any useful information about how to go on further?

-----------------
Small update:
Now It´s a usb communication device in my system profile (USB)
Code: [Select]
  Produkt-ID: 0x0042
  Hersteller-ID: 0x2341
  Version: 0.01
  Seriennummer: 75232333435351700000
  Geschwindigkeit: Bis zu 12 MBit/s
  Hersteller: Arduino (www.arduino.cc)
  Standort-ID: 0x04100000 / 5
  Verfügbare Stromstärke (mA): 500
  Erforderliche Stromstärke (mA): 100


I know it´s German, but I think you get the point.

So now what? (Still 2 red lights on my board and this failure message above)
best regards,
Tobias

Louis Davis

Since the 16U2 was in DFU mode, that indicates it was not loaded with the usbserial firmware at the factory. More than likely, the 2560 was not loaded with bootloader firmware, as well.

You will need another Arduino or an ISP to load the bootloader firmware into the 2560.

Otherwise, you could return it for a replacement that has the appropriate firmware loaded.

James C4S


I've just had 2 red lights on my board

The color of the LED has nothing to do with the status of the board.

Cheap manufacturers (who do not contribute to the Arduino project) use red LEDs because they are slightly cheaper than green.  Another cost saving move is to not program the chips on the board.  Which is the problem you are encountering.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

Go Up