Go Down

Topic: Programming a Mega2560 via BT (Read 483 times) previous topic - next topic

Tmp2k

So I can program a Duemilanove just fine using an RN-42.  I've broken out the DTR pin and connected it via a cap.  Everything works fine.

I switched to a Mega 2560 and it just won't work.  First off I couldn't get it to auto reset, but though trial and error I fixed this by upping the cap to 10uF.

Not it auto resets just fine and appears to do something for a few seconds, but then just continues the old program and AVRdude hangs.

I've tried changing the BT device to 115.2kbps and 57.6kbps, neither work.

Any thoughts? I've run out of ideas.

James C4S

Are you able to load the same code to the 2560 via USB?
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

pito

DTR/CTS/RTS signals do not work with BT modules. You need to set BT module according to:
http://arduino.cc/forum/index.php?topic=132179.0
It works fine with my UNO..


Tmp2k


Are you able to load the same code to the 2560 via USB?


Yes if I swap the BT module for FTDI and leave everything else the same it works fine.

Tmp2k


DTR/CTS/RTS signals do not work with BT modules. You need to set BT module according to:
http://arduino.cc/forum/index.php?topic=132179.0
It works fine with my UNO..




As I said I've broken out the DTR pin from the BT module.  I can reprogram other Arduinos just fine, and I it's resetting the Mega 2560, but it's just not syncin up.

Tmp2k

Does anyone have any suggestions, I don't know what else to try :(

Go Up