Go Down

Topic: lilypad usb blinks alot and makes a hiss sound (Read 1 time) previous topic - next topic

Paul Beaudet

Feb 12, 2013, 03:36 am Last Edit: Feb 12, 2013, 03:43 am by Paul Beaudet Reason: 1
This has occurred since receiving the device, I'm getting the feeling it shipped without the magic smoke.
As soon as the lilypad is plugged into my computer it starts to make a subtle high pitch whining sound almost like what you would expect to hear from a dc wall adapter. The two smd leds alternate in the following manner unmarked (pin 13?) twice, rx once. To me it looks like it is constantly resetting.

It takes a while for the ide to recognize the serial port its on, but I made sure the board and port were set right. When I try to upload the tx and rx will light but ultimately it feel as though it is interrupted by the odd blink sequence described above with vary frequencies of hissing. Then followed by this message from the ide.

Code: [Select]
Binary sketch size: 4,600 bytes (of a 28,672 byte maximum)
processing.app.debug.RunnerException: Couldn't find a Leonardo on the selected port. Check that you have the correct port selected.  If it is correct, try pressing the board's reset button after initiating the upload.
at processing.app.debug.AvrdudeUploader.uploadViaBootloader(AvrdudeUploader.java:152)
at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:67)
at processing.app.Sketch.upload(Sketch.java:1671)
at processing.app.Sketch.exportApplet(Sketch.java:1627)
at processing.app.Sketch.exportApplet(Sketch.java:1599)
at processing.app.Editor$DefaultExportHandler.run(Editor.java:2380)
at java.lang.Thread.run(Thread.java:722)


Tried the reset after initiating the upload
I managed to upload a sketch once a couple of days ago but was unable to repeat the same upload.
Is the lilypad usb supposed to hiss?
I just get the feeling its cooked
I got this for christmas... do you think sparkfun would trade me for a working one?

MisterResistor

Are you absolutely sure you have the right driver installed? I'll be honest, I don't know if the Lily Pad uses the 'Leornardo' driver, but that looks a little wonky to me.

Paul Beaudet

Quote
I don't know if the Lily Pad uses the 'Leornardo' driver

I think that the MEGA32u4 chip is generally referred to as the Leonardo since it uses that chip.
I used a usb 1.1 hub for the arduino micro and got a similar error referring to the micro (also a MEGA32u4) as the Leonardo 
(using a usb2 port remedied that specific issue, took me a while to figure that out though)
Quote
Are you absolutely sure you have the right driver installed?

I didn't think of that, never had to bother with them in linux for the uno or the micro.
Maybe there is no automagical secret sauce for the lilypad? Though I would think the drivers are the same for the Leonardo / Micro / usb lilypad

Paul Beaudet

Sparkfun is sending me a new board, problem solved

Paul Beaudet

... and the new board does the exact same thing right out of the box....

on this page(http://arduino.cc/en/Guide/ArduinoLilyPadUSB ) it says to reset the the boot-loader by double clicking reset on upload.

I've tried that with both in various manners

I must not be the only one with this problem, is there anyone with a usb lilypad that can give me a step by step on your upload process?

Go Up