Pages: [1]   Go Down
Author Topic: Arduino shows differences running same sketch uploaded from different computers  (Read 205 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 25
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Greetings all. I have a particular troubling issue that my friend and I cannot solve.

We wrote a sketch using my laptop. When I upload the sketch to an arduino from my laptop, everything works fine.

When we upload the same sketch from my friend's computer to the same exact arduino, the sketch does not run properly. Some aspects of the sketch seem to work okay- reading values from a potentiometer, outputting a signal via PWM- but some aspects of the sketch do not work at all, or appear to have errors.

Has anyone ever encountered this issue?

We are both running windows 7 and have the latest version of the arduino IDE and drivers installed.

Any assistance you can offer would be most appreciated.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 25
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I should say that we are using an arduino diecemila with an ATMEGA328 chip.
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 176
Posts: 12283
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


http://arduino.cc/forum/index.php/topic,97455.0.html

Pay close attention to #6, fifth bullet.
Logged

East Anglia (UK)
Online Online
Faraday Member
**
Karma: 89
Posts: 3464
May all of your blinks be without delay()
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I can explain all of the differences that you have described.
Finished !
Logged

Please do not send me PMs asking for help.  Post in the forum then everyone will benefit from seeing the questions and answers.

Pages: [1]   Go Up
Jump to: