Pages: [1]   Go Down
Author Topic: DUE: USB Keyboard demos doesn't work  (Read 596 times)
0 Members and 1 Guest are viewing this topic.
Germany
Offline Offline
Jr. Member
**
Karma: 0
Posts: 57
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,
I have both an Arduino Due and a Taijiuno Clone for one week now. When I connected the Due to my Win7 machine the first time it was recognized as a Due and as a keyboard dependent on the connector.

Now I played with some sketches including USB KeyboardLockout and KeyboardMessage but the Due isn't beeing recognized as a keyboard anymore. When connected to the PC I find in the control panel->devices tab the devices Arduino Due Programming Port (COM14) and a Arduino Due with a warning triangle. I tried to fix this but a specific(?) driver could not be found. Similar behaviour is for the clone.

Any idea what's going on here?
Logged

Global Moderator
Offline Offline
Brattain Member
*****
Karma: 452
Posts: 18694
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Are the new sketches successfully uploading? What does the IDE say after you hit Upload?
Logged

Germany
Offline Offline
Jr. Member
**
Karma: 0
Posts: 57
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yep, uploading works. I simply load the example and shift it to the uC.
When the uC is erased the device is recognised as a GPS Camera. I wonder what's going on here. I'm using IDE with Ver 1.5. All is set by default.
Logged

Global Moderator
Offline Offline
Brattain Member
*****
Karma: 452
Posts: 18694
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

What does the IDE say after you hit Upload?
Logged

Germany
Offline Offline
Jr. Member
**
Karma: 0
Posts: 57
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,
I repeated the prob with the KeyboardMessage example (I have Version 1.5.1r2 of the arduino IDE).
The IDE gives:

Erase flash
Write 10208 bytes to flash

[Then the verify progress bars appear]

Verify 10208 bytes to flash
Verify successful
Set boot flash true
CPU reset.

As always, the Icon changes from "Arduino GPS-Camera" to "Arduino Due" with the warning triangle. Also it is not possible to install a Windows7 driver since the button "update driver..." in the update driver dialog is disabled.

Logged

Austin, TX
Offline Offline
God Member
*****
Karma: 12
Posts: 524
carpe diem
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Can you try 1.5.2?

There was a problem with the Native USB code that was fixed in 1.5.2
Logged

Germany
Offline Offline
Jr. Member
**
Karma: 0
Posts: 57
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello Louis,
success!
Thank you for your help.

When Nick asked me about the output messages of the IDE  (though I stated in the first post everything is fine) I had the slight suspicion that there is something completely wrong outside my influence.
Now I can do further usb tinkering. Are you, Nick or Louis in the "USB business"?
Have some years of AVR/PIC tinkering now but USB is still black art...

Anyway, thank you, guys.
Logged

Global Moderator
Offline Offline
Brattain Member
*****
Karma: 452
Posts: 18694
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

No I'm not in the USB business. I've read about it, and it's damn complex.
Logged

Pages: [1]   Go Up
Jump to: