Go Down

Topic: Can no longer upload from my MacBook Pro, can upload from another (Read 851 times) previous topic - next topic

sonvivant

Feb 15, 2013, 03:11 am Last Edit: Feb 15, 2013, 04:38 am by sonvivant Reason: 1
Mac 10.7.5
Leonardo and Uno
I was able to upload from my computer until recently. Changes since my last Arduino project that may have effect: recent update to Java, and installation of Emacs for a course I enrolled in and subsequently dropped. I removed Emacs with AppCleaner with no change.

I have tried the troubleshooting steps from the Guide. I can see my Arduino on the serial port, and it gets power and the L LED is lit. I tried a Loop-back test and, believing I did it right, it passed. (During the Loop-back test, I observed the Tx and Rx LEDs on the board lighting up every time I pressed a key, and with the Terminal screen split, I saw the letters typed appear in the second pane.)

I am able to successfully upload a sketch from another MacBook with the same OS version. I have tried rebooting and repairing permissions on my own MacBook Pro with no change. I don't know how to see what if anything is holding on to my serial port, if that is what is keeping the Arduino from responding.

With thanks in advance, can someone help me get my upload functionality back?

verbose output from Leonardo:
Code: [Select]
Binary sketch size: 6,064 bytes (of a 28,672 byte maximum)
Forcing reset using 1200bps open/close on port /dev/cu.usbmodemfa131
PORTS {/dev/tty.usbmodemfa131, /dev/cu.usbmodemfa131, /dev/tty.Bluetooth-Modem, /dev/cu.Bluetooth-Modem, /dev/tty.GavinsiPhone-WirelessiAP, /dev/cu.GavinsiPhone-WirelessiAP, /dev/tty.Bluetooth-PDA-Sync, /dev/cu.Bluetooth-PDA-Sync, } / {/dev/tty.usbmodemfa131, /dev/cu.usbmodemfa131, /dev/tty.Bluetooth-Modem, /dev/cu.Bluetooth-Modem, /dev/tty.GavinsiPhone-WirelessiAP, /dev/cu.GavinsiPhone-WirelessiAP, /dev/tty.Bluetooth-PDA-Sync, /dev/cu.Bluetooth-PDA-Sync, } => {}
PORTS {/dev/tty.usbmodemfa131, /dev/cu.usbmodemfa131, /dev/tty.Bluetooth-Modem, /dev/cu.Bluetooth-Modem, /dev/tty.GavinsiPhone-WirelessiAP, /dev/cu.GavinsiPhone-WirelessiAP, /dev/tty.Bluetooth-PDA-Sync, /dev/cu.Bluetooth-PDA-Sync, } / {/dev/tty.usbmodemfa131, /dev/cu.usbmodemfa131, /dev/tty.Bluetooth-Modem, /dev/cu.Bluetooth-Modem, /dev/tty.GavinsiPhone-WirelessiAP, /dev/cu.GavinsiPhone-WirelessiAP, /dev/tty.Bluetooth-PDA-Sync, /dev/cu.Bluetooth-PDA-Sync, } => {}
Uploading using selected port: /dev/cu.usbmodemfa131
/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega32u4 -cavr109 -P/dev/cu.usbmodemfa131 -b57600 -D -Uflash:w:/var/folders/v3/t3w8h12n7d11rxr23js97_5c0000gn/T/build2180696007194724475.tmp/MIDI_STEPPER_SANDBOX_V6.cpp.hex:i

avrdude: Version 5.11, compiled on Sep  2 2011 at 18:52:52
        Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
        Copyright (c) 2007-2009 Joerg Wunsch

        System wide configuration file is "/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf"
        User configuration file is "/Users/gavin/.avrduderc"
        User configuration file does not exist or is not a regular file, skipping

        Using Port                    : /dev/cu.usbmodemfa131
        Using Programmer              : avr109
        Overriding Baud Rate          : 57600
        AVR Part                      : ATmega32U4
        Chip Erase delay              : 9000 us
        PAGEL                         : PD7
        BS2                           : PA0
        RESET disposition             : dedicated
        RETRY pulse                   : SCK
        serial program mode           : yes
        parallel program mode         : yes
        Timeout                       : 200
        StabDelay                     : 100
        CmdexeDelay                   : 25
        SyncLoops                     : 32
        ByteDelay                     : 0
        PollIndex                     : 3
        PollValue                     : 0x53
        Memory Detail                 :

...much of this report has been edited for brevity due to character restrictions on the post. All text preserved in the attachement.....

avrdude: verifying ...
avrdude: 6064 bytes of flash verified
avrdude: Send: L [4c]
avrdude: Recv: . [0d]
avrdude: Send: E [45]
avrdude: Recv: . [0d]

avrdude done.  Thank you.



sonvivant

I should add that I have also read a number of other threads on this forum relating to avrdude and have not found a solution even when other posters have. And, man, there sure are a lot of avrdude posts on this board!

Louis Davis

Both of the logs you attached indicate you are trying to connect to the Bluetooth port.

You need to make sure you have the correct port selected for your Arduinos.

sonvivant

Yes, how embarrassing. I had already made such confirmations on my way through the troubleshooting guide but neglected to do so when I returned to the upload attempt so I could capture that text.

I have now double checked port and board assignments are correct. I have updated and edited the verbose report from the Leonardo above, and omitted the Uno report, because I was having difficulty keeping the post under the max character restriction. An attachment to the original post includes the full text which exceeds 9500 characters.

paparomeo

Hi

I have also had this problem  with a MacBook Pro.
All was ok on my laptop with Windows XP but not on my MBP.
After a lot of google search no more :(
I have finally solved the problem by changing the USB cable by another which I've had with an external USB DVD burner.
This one have two USB plugs. One of them is fully cabled and the other had only the power.
With this cable all is working great now.


I hope that will be good for you too.

sonvivant

Thanks for your reply paparomeo. In fact I have already tried different USB cables and it is no help. In fact, I can successfully upload using any USB cable from a different computer but that same cable still will not work from my own.

Louis Davis

I am confused.

The newly updated log from your leonardo looks like it successfully uploaded and verified the MIDI_STEPPER_SANDBOX_V6.cpp.hex

Are you still having problems uploading?

sonvivant

Hm. No, I am not. I just successfully uploaded to both Leonardo and Uno... But I am not sure what changed to allow me to upload now when I couldn't before.
Here's hoping I can keep it!

Thanks all.

Go Up