Go Down

Topic: Upload problems on Debian [Fixed by grabbing latest IDE] (Read 594 times) previous topic - next topic


Feb 12, 2013, 04:45 pm Last Edit: Feb 13, 2013, 01:07 am by nigelbarker Reason: 1

I'm running squeeze, and trying to upload my very first bit of code to a brand new Mega2560 using the command line.

Running make upload gives :-

nigelb@wdccsdp09466:~/arduino$ make upload

Uploading to board...
*GUESSING* at serial device: /dev/ttyACM0

stty -F /dev/ttyACM0 hupcl
/usr/bin/avrdude  -DV -p atmega1280 -P /dev/ttyACM0 -c arduino -b 57600 -U flash:w:blinkled.hex:i
avrdude: stk500_recv(): programmer is not responding

avrdude done.  Thank you.

make: *** [upload] Error 1


Adapting the avrdude command slightly to add a -v (verbose) gives :-

nigelb@wdccsdp09466:~/arduino$ /usr/bin/avrdude  -DV -p atmega1280 -P /dev/ttyACM0 -v -c arduino -b 57600 -U flash:w:blinkled.hex:i

avrdude: Version 5.10, compiled on Jun 27 2010 at 00:38:29
        Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
        Copyright (c) 2007-2009 Joerg Wunsch

        System wide configuration file is "/etc/avrdude.conf"
        User configuration file is "/home/nigelb/.avrduderc"
        User configuration file does not exist or is not a regular file, skipping

        Using Port                    : /dev/ttyACM0
        Using Programmer              : arduino
        Overriding Baud Rate          : 57600
avrdude: stk500_recv(): programmer is not responding

avrdude done.  Thank you.


The mega shows a continuous green light, an evenly blinking L light, and the RX led flashes when i try to upload (but the tx doesn't).

Any clues for a newbie?



Don't know if it may help, but here is a discussion about usb settings. The only thing I can see is that data rate is usually 115200, while in your case is 57600.




Well problem fixed, in as much as I have now uploaded a sketch.

Installed arduino with apt-get, but that just gave me a gui which still didn't work (no serial port under tools).

After much playing around I grabbed the most recent version of the code from the website, and it worked :-)

I prefer Debian stable as it is, well, stable, but it does mean you are running old versions of the code.
(the backport seems to have the same version as is already in squeeze, so that didn't help)

Grabbing the code wasn't bad, no install just run the executable after uncompressing.



Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131