Pages: [1]   Go Down
Author Topic: Help with Colorduino  (Read 1813 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi!

I bought myself a nice Colorduino with an 8x8 led matrix from ebay and I'm trying to get started with it. I've installed the IDE (with Ubuntu 12.04 64bit), downloaded and installed the library from http://blog.lincomatic.com/ and built the example. But I can't seem to flash it. I've google a lot and found that I could use an FTDI cable, which I have connected according to this:

 FTDI RX -> Colorduino TX
 FTDI TX -> Colorduino RX
 FTDI RTS -> Colorduino DTR
 FTDI GND -> Colorduino GND

I use an external 5v power adapter as well. I've set the board to Arduino Nano w/ATmega 328 and the programmer is default (AVRISP mkII). The port is ttyUSB0 and I have set permissions to read/write to it (had to do that, even though I'm in the dialout group, don't know why). I get the following output:

ioctl("TIOCMGET"): Broken pipe
ioctl("TIOCMGET"): Broken pipe
avrdude: stk500_recv(): programmer is not responding
ioctl("TIOCMGET"): Broken pipe

I really don't know what to do now, so all input is welcome!
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Can anyone at least tell me if you've got it to work using an FTDI cable?
Logged

Tucson, AZ
Offline Offline
Sr. Member
****
Karma: 8
Posts: 311
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I would first plug it in and look at the output of "dmesg". You should see recent activity indicating Linux found the USB device and has created a device such as /dev/ttyUSB0 or some such entry. If you don't see this - this is your first hit at a problem. If you do see it, you might try a common program like kermit and add a loop back to the far end of the cable. Then, simply type something. You should see it echo back as if you were typing into an editor. If all that works and the Arduino SDK still doesn't - I would next suspect that the Arduino SDK is trying to create lock files to prevent other programs from using the /dev/ttyUSB0 device (or what ever it was called) but failed. At this point, I (briefly) ran the Arduino SDK as root as a test.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I would first plug it in and look at the output of "dmesg". You should see recent activity indicating Linux found the USB device and has created a device such as /dev/ttyUSB0 or some such entry. If you don't see this - this is your first hit at a problem. If you do see it, you might try a common program like kermit and add a loop back to the far end of the cable. Then, simply type something. You should see it echo back as if you were typing into an editor. If all that works and the Arduino SDK still doesn't - I would next suspect that the Arduino SDK is trying to create lock files to prevent other programs from using the /dev/ttyUSB0 device (or what ever it was called) but failed. At this point, I (briefly) ran the Arduino SDK as root as a test.

The port is discovered as it should and I have used this FTDI cable with an Arduino Pro before, so it's nothing wrong with that. What I'm wondering is if anyone got it to work with the colorduino as it is not build for using an FTDI cable directly. Are everyone using another modified arduino board in between? Seems a bit stupid that you have to do it that way. Is there really no better way to flash the colorduino?
Logged

San Francisco
Offline Offline
Newbie
*
Karma: 0
Posts: 23
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I had the same problem. I was trying to upload to Colorduino through an FTDI cable but was getting "stk500_recv() programmer is not responding" errors. It resolved when I also connected the DTR pin of my FTDI cable to the Colorduino DTR pin, in addition to the four pins described in Lincomatic's "Lampduino" Instructable.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Just wanted to say "thanks!" as this helped me get my Colorduino "2.0" working (I'm not sure what makes it a 2.0 other than a slightly different connector - it was from HobbyKing FWIW). Shame I couldn't keep a copy of the original demo that was on it... it was kinda nice, though this is better.
Logged

Méry-sur-Cher, France.
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi everybody,

Thanks this topic, I manage to upload the 'ColorduinoPlasma' example to my Colorduino v2.0.
But now it is completly frozen and not anymore working.

There is no error message and the upload seems successfull.
The TX and RX leds are blinking on the FTDI card during the transfer.

I used the colorduino library and code v1.24 from https://github.com/lincomatic/Colorduino/downloads

Any idea to fix this problem ?

EDIT :

I'm not anymore stuck, I try another schemas from https://github.com/tinkering-arduino/ColorShield_8x8_RGB_LED
and my device is showing something again.. it is not really nice but at least I know I'm able to transfer some code in it..

But definitly this library as something wrong with my colorduino 2.0 !

Thanks

« Last Edit: November 03, 2013, 11:06:26 am by panguitou » Logged

Pages: [1]   Go Up
Jump to: