Go Down

Topic: Led on pin 13 stopped blinking (Read 777 times) previous topic - next topic


I have no experience with arduino, but I follow a workshop offered by an university teacher. I've build my arduino and I tried and it just now. The power led worked, but the led on pin 13 didn't blink when I used a 12v adapter. I tried again after some fiddling with the microcontroller, and it worked! Then I pushed the microcontroller onto its connector a bit more, to make sure it was in the right place, and now I can't get it to work again. I am no good at soldering, but the default blink program did work.
Does anyone have any idea what could have happened? Did I broke my microcontroller? Is it possible that i broke a connection or something like that, when I tried to attach the microcontroller more firmly?

Any help is appreciated! (this kinda sucks, I am pretty sure I did something wrong or not careful enough, but I have no idea where)...

Paul Beaudet

I think your being too careful with it. The whole point of a cheap learning platform like arduino is to be able to experiment without too much fuss.

That being said, what else have you tried? Does the blink sketch work solely powered by usb?

Is this a board that gets used by many students? Odd things start happening when pins are shocked.

maybe you can grab a resistor and led then try another pin and see what happens

Sounds like a dry/poor solder joint, or maybe a bent leg on the microcontroller?


Sounds like a dry/poor solder joint, or maybe a bent leg on the microcontroller?


I think I bent two legs of the microcontroller indeed, I de- and reattached the thing a couple of times (to try if that would make a difference) and I couldn't avoid to bent the legs on one side. It could be a poor solder joint, but in that case I must have somehow broke after the short period where it worked (and that seems unlikely to me).
Should I buy a new microcontroller?

The legs should be straight, and should slide into the socket.
Doing so isn't easily (especially the first times!) so I wouldn't be afraid asking for some help there.

A dry joint is one where little solder actually connects the two conductors, and typically fails after a tap (or a bang!).
I would get help and check things like the supply voltage actually getting to the chip, and then other critical points on the board, but you have to be careful as it is easy to let a multimeter probe slip from a single pin, and short two pins out!

Sorry, in short you need someone there physically to give you a hand imho.


Thanks for the reactions! With the help of a teacher, I finally figured out the problem: the microcontroller just wasn't working. The teacher was so kind to just give me a new one, and now it works :)

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131