Go Down

Topic: [SOLVED] uploads fail from debian to due: "no device found on ttyacm0" (Read 2 times) previous topic - next topic

aude

from this post: http://arduino.cc/forum/index.php?topic=63259.0
i tried to reload usbserial and cdc_acm when i noticed usbserial hadn't loaded.
and usbserial doesn't load when i restart and replug in the due- even though dmesg reports the above.

so i modprobe usbserial and reload cdc_acm, but nothing changes.

setserial -G /dev/ttyACM0 gives:
Cannot get serial info: Invalid argument

...not really sure what to do think about that..

nigelbarker

Sounds to me like Debian sees it ok, just the loader doesn't.

My version is 1.0.3 - 2012.12.10 (downloaded yesterday) but is the 64 bit version.

I downloaded the tgz, unzipped it and ran the executable as root.

However, I did do a fair amount of playing first (trying to get the command line to work), and am using a different board.

I'll have another play this evening, but I don't think I'm going to be much help.

Nige

aude

so after spending *hours* surfing and testing, the solution was incredibly simple.
when i plug in the due, the baud rate is set at 115200 automatically. all i have to do is set the baud rate to 1200 before every upload and all uploads are successful from the ide!
i suppose i'll make that a more permanent fix (with udev?) but for now, i don't mind hitting [up] at the terminal.

for anyone having the same problem, i first found the solution while in windows.
i followed the instructions on this site to set the baud rate with the 'mode' command from a command prompt:
https://sites.google.com/site/arduinodueatmelstudio/home/uploading-code-to-due

the linux equivalent, i got from:
http://stackoverflow.com/questions/8877269/writing-to-serial-port-from-linux-command-line.

in case those sites aren't around as long as this one, the commands issued were:

mode com3: baud=1200 data=8 parity=n stop=1
from the command prompt
and

stty -F /dev/ttyACM0 speed 1200 cs8 -cstopb -parenb
from the terminal.

cheers

Justin


Danoino

I have the same problem as described at the top:
When trying to upload a sketch via the USB Programming Port the following error message appears:

Code: [Select]
No device found on /dev/tty.usbmodem1421

However, when I connect the Arduino via the Native USB Port the sketch is uploaded and runs just fine.

I am using an Arduino Due, Arduino IDE 1.5.4 and Mac OS 10.9 (Mavericks).
Would the problem in my case also be the Baud rate? If yes, how do I change it on a Mac?

I would be very happy about any help.

Go Up