Go Down

Topic: Arduino as ISP for ATtiny Hardware not recognized (Read 1 time) previous topic - next topic

hctiM

When moving the Attiny folder in the hardware folder and starting the IDE the Attiny option does not show up in any menu.

Same here...have tried uninstalling, moving libraries. Granted, I am new to this and don't have a clue but I am quite sure I have followed all instructions carefully for well over 5 hours now.....still nada TTiny listed under boards...discouraged to say the least.

PeterVH

Are you really trying to use the Due as ArduinoISP?

If not, use the ide 1.0.3 instead, it works.

If yes, it can be done but it does not work out of the box, and it is not very practical because the Due's SPI signals are 3V3... I managed to isp a leonardo and a duemilanove using the due as programmer. I powered theses targets with 3V3 to do this. I tried the same with an attiny but that did not work for some reason...
Also you need to get the latest ArduinoISP from rsbohn's github, because that one uses the SPI library instead of thge AVR's SPI register interface.
(I plan a write up about this...)

To use the tiny core, first load ArduinoISP in the due using ide 1.5.2 and then do the tiny stuff using ide 1.0.3.

Go Up