Go Down

Topic: Arduino IDE 1.0.3 can't find libraries in Linux Mint 14 (Read 572 times) previous topic - next topic

Programs that use libraries fail to compile.  Some specifics:
Arduino:Uno
OS:  Linux Mint 14
IDE version:  1.0.3 (upgraded from 1.0.1)

Once I put the user into the right group, simple programs compile,upload, and produce expected results on the serial monitor.  That seems to indicate that everything is fine, until I start to use libraries.  Simple programs like "hello world" and producing an ASCII table work well.

When I try to use libraries, compiles fail, with lots of error messages. Library files are both a header and a c++ file in what look like appropriate locations. 
The tree linux program produces:


rc@cerebralcortex ~ $ tree /usr/share/arduino/libraries/usr/share/arduino/libraries
??? Adafruit
?   ??? Adafruit_GFX.cpp
?   ??? Adafruit_GFX.h
?   ??? Adafruit_LEDBackpack.cpp
?   ??? Adafruit_LEDBackpack.h
?   ??? Wire.h
?   -- clipped -- to reduce size -- (unessential libraries are present but not listed)
??? Wire
    ??? examples
    ?   ??? digital_potentiometer
    ?   ?   ??? digital_potentiometer.ino
    ?   ??? master_reader
    ?   ?   ??? master_reader.ino
    ?   ??? master_writer
    ?   ?   ??? master_writer.ino
    ?   ??? SFRRanger_reader
    ?   ?   ??? SFRRanger_reader.ino
    ?   ??? slave_receiver
    ?   ?   ??? slave_receiver.ino
    ?   ??? slave_sender
    ?   ??? slave_sender.ino
    ??? keywords.txt
    ??? utility
    ?   ??? twi.c
    ?   ??? twi.h
    ??? Wire.cpp
    ??? Wire.h

108 directories, 170 files
---------------------------------------------------------------
and


rc@cerebralcortex ~/sketchbook $ tree
.
??? Adafruit_7_SegmntDisplayTest_1_Display
?   ??? Adafruit_7_SegmntDisplayTest_1_Display.ino
??? HelloWorld
?   ??? HelloWorld.ino
??? HereIsSomeMath
?   ??? HereIsSomeMath.ino
??? libraries
?   ??? Adafruit_GFX
?   ?   ??? Adafruit_GFX.cpp
?   ?   ??? Adafruit_GFX.h
?   ?   ??? glcdfont.c
?   ?   ??? license.txt
?   ?   ??? README.html
?   ?   ??? readme.txt
?   ??? Adafruit_LEDBackpack
?   ?   ??? Adafruit_LEDBackpack.cpp
?   ?   ??? Adafruit_LEDBackpack.h
?   ?   ??? glcdfont.c
?   ?   ??? README.htm
?   ?   ??? readme.txt
?   ?   ??? README.txt
?   ??? Wire
?   ??? examples
?   ?   ??? digital_potentiometer
?   ?   ?   ??? digital_potentiometer.ino
?   ?   ??? master_reader
?   ?   ?   ??? master_reader.ino
?   ?   ??? master_writer
?   ?   ?   ??? master_writer.ino
?   ?   ??? SFRRanger_reader
?   ?   ?   ??? SFRRanger_reader.ino
?   ?   ??? slave_receiver
?   ?   ?   ??? slave_receiver.ino
?   ?   ??? slave_sender
?   ?   ??? slave_sender.ino
?   ??? keywords.txt
?   ??? utility
?   ?   ??? twi.c
?   ?   ??? twi.h
?   ??? Wire.cpp
?   ??? Wire.h
??? NSB_Timer
?   ??? NSB_Timer.ino
??? sevenseg
?   ??? sevenseg.ino
??? timer
. ??? timer.ino


Adafruit tech support suspected a mislocated Wire program, but it appears to be in the correct place.  I have two versions of the file Wire.h and two versions of Wire.cpp, and both have been checked.

Further details, including error dumps are at:

http://forums.adafruit.com/viewtopic.php?f=22&t=36991&p=183060#p183060 so I won't waste too much space.  As you can see, I started over on the Adafruit forums, but they didn't have much Linux experience, and suggested this forum.  Thanks in advance for the help.

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy