Go Down

Topic: Error Uploading Sketches getsync(): not in sync (Read 1 time) previous topic - next topic


Recently I started using my Uno R2 as I got my teacher to start using the arduino platform in my digital electronics class. All went well for a long time and i was making programs and having fun but recently after uploading this code...

Code: [Select]
long readTemp() {
  long result;
  // Read temperature sensor against 1.1V reference
  ADMUX = _BV(REFS1) | _BV(REFS0) | _BV(MUX3);
  delay(2); // Wait for Vref to settle
  ADCSRA |= _BV(ADSC); // Convert
  while (bit_is_set(ADCSRA,ADSC));
  result = ADCL;
  result |= ADCH<<8;
  result = (result - 125) * 1075;
  return result;

void setup() {

void loop() {
  Serial.println( readTemp(), DEC );

I get this error every time i try to upload a new sketch to the R2

"avrdude: stk500_getsync(): not in sync: resp=0x00"

The program above is working and is communication over serial properly. I have tried to burn the boot loader but i get the same result. I have also tried pressing the reset before uploading. I do notice also the Arduino does reset when it starts to upload and tries to communicate over serial as the RX and pin 13 led blink before the error appears. I have tried this on 4 separate computers all running windows 7 x64 and it had previously worked on the computers until that last program was uploaded. I have used this code before with out having this problem. Any help would be great thanks.

Also note after attempting to upload it resumes the code from above.

Nick Gammon


Nothing is connected to the arduino its just it and the computer.


I have the same problem on my Arduino Uno, i have tried changing the serial port, restarting the program, etc

Any Ideas?

Nick Gammon

Personally I destroyed one of my Unos accidentally, I guess by touching it when I had "static" on my hand. That maybe is what happened. Try the "loopback test" (see sticky). You could also try my "chip detector" sketch here:


You need a second Uno to run that, but it could confirm whether or not your main processor chip is OK.

Go Up