Pages: [1]   Go Down
Author Topic: Using rele 12V  (Read 509 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 1
Posts: 30
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have http://dx.com/p/4-channel-12v-low-level-trigger-relay-module-for-arduino-152281 module but i can't put ON the relay. I put an external supply of 12V in the Vcc pin of the module and connect the GND of arduino and the GND cable of the power supply in a protoboard. Then i connect the signal pin of arduino in the Signal pin of the relay module. I see that the led is always ON and the current flows although I charge the blink example...
Can anyone help me please??
Thanks!
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 28
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Can you tell us which pins you've connected everything too and give us your code.
Logged

Manchester, UK
Offline Offline
Newbie
*
Karma: 0
Posts: 24
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

have you connected the correct pin on your board?
In the blink example this is pin 13 as far as I know.

Is your Arduino running?

Is the red power LED on the relay board on?
Logged

Offline Offline
Newbie
*
Karma: 1
Posts: 30
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have changed the blink example to connect my pin. The red power led on the relay board is always on. Next tuesday i will give you photos of the connexions and the code.
Thanks!
Logged

Offline Offline
Newbie
*
Karma: 1
Posts: 30
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have attached photos of the connexions. The brown cable that goes to the light must go in the middle of the relay 4 and the other goes next to this connector.
http://imageshack.us/photo/my-images/825/foto190213111605.jpg/
http://imageshack.us/photo/my-images/7/foto190213111626.jpg/
http://imageshack.us/photo/my-images/839/foto190213111633.jpg/
http://imageshack.us/photo/my-images/547/foto190213111637.jpg/
http://imageshack.us/photo/my-images/713/foto190213111649.jpg/
http://imageshack.us/photo/my-images/4/foto190213111657.jpg/
http://imageshack.us/photo/my-images/546/foto190213112554.jpg/

The Code:

 int relayPin = 8;                 
 void setup(){
   pinMode(relayPin, OUTPUT);     
 }
 void loop() {
   digitalWrite(relayPin, HIGH); 
   delay(2000);                   
   digitalWrite(relayPin, LOW);   
   delay(2000);
}

If I use this I have the red led of the relay module always ON and also the green led of the 4th relay always ON and it must be 2 seconds ON and 2 seconds OFF.


Thanks!
Logged

Offline Offline
Newbie
*
Karma: 1
Posts: 30
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Any suggestion??
Logged

Pages: [1]   Go Up
Jump to: