Pages: [1]   Go Down
Author Topic: Xbee transform 0x00 in 0x80  (Read 861 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello,

When i try this simple code :
Code:
void setup() {
  Serial.begin(115200);
}

void loop() {
  Serial.write((uint8_t)0);
  delay(1000);
}

With this configuration :

X-CTU - driver FTDI 2.8.14 - Mega 2560 - Xbee shield - Xbee 1mw s1   
<-->     
Xbee 1mw s1 - Xbee Usb Explorer - driver FTDI 2.8.14 - X-CTU


the byte 0x00 is transformed in 0x80 on the receiver
In the attachment, COM8 is the sender, COM7 the receiver.

Can someone confirm and/or explain ?

Jérôme


* X-ctu.jpg (58.25 KB, 934x600 - viewed 13 times.)
Logged

'round the world...
Offline Offline
Faraday Member
**
Karma: 42
Posts: 3323
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Have you tried smaller baud rates?
Logged

Eu não sou o teu criado. Se respondo no fórum é para ajudar todos mediante a minha disponibilidade e disposição. Responder por mensagem pessoal iria contra o propósito do fórum e por isso evito-o.
Se realmente pretendes que eu te ajude por mensagem pessoal, então podemos chegar a um acordo e contrato onde me pagas pela ajuda que eu fornecer e poderás então definir os termos de confidencialidade do meu serviço. De forma contrária toda e qualquer ajuda que eu der tem de ser visível a todos os participantes do fórum (será boa ideia, veres o significado da palavra fórum).
Nota também que eu não me responsabilizo por parvoíces escritas neste espaço pelo que se vais seguir algo dito por mim, entende que o farás por tua conta e risco.

Dito isto, mensagens pessoais só se forem pessoais, ou seja, se já interagimos de alguma forma no passado ou se me pretendes convidar para uma churrascada com cerveja (paga por ti, obviamente).

0
Offline Offline
Full Member
***
Karma: 1
Posts: 185
www.rocketscream.com
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

It might be the XBee module baud rate itself. Also check the baud rate in the X-CTU is the one matches the module baud rate.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

In fact, i want to wireless upload my mega 2560 via xbee and the bootloader is 115200 baud.

I've verified at 57600, and all is OK.
I've compiled the bootloader with this options in the Makefile at line 341 :

Code:
mega2560: CFLAGS += -D_MEGA_BOARD_ -DBAUDRATE=57600 -DUART_BAUDRATE_DOUBLE_SPEED=0 -fno-inline

I put UART_BAUDRATE_DOUBLE_SPEED=0 due to http://code.google.com/p/arduino/issues/detail?id=394

Upload the bootloader, reconfigure the xbees

All is OK, avrdude can communicate via xbee
Thank you very much
Jérôme
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 32
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

To be clear:
- go in: C:\...\Arduino\arduino-1.0.3\hardware\arduino\bootloaders\stk500v2
- modify the makefile as said
- write "make mega2560"
Logged

Pages: [1]   Go Up
Jump to: