Go Down

Topic: avrdude: stk500_getsync(): not in sync: resp=0x30 (Read 555 times) previous topic - next topic

dirkman

My Arduino Uno is fresh out of the box.  I've installed (I think) the WinVista drivers successfully.

I'm just working on loading and running blink().  The COM port seems to be recognized, but as soon as the board has power, I get some random blinkiness on L1, then it cycles on/off about one cycle/sec.  Same behavior if I press the reboot button.  I get the same error on upload:
avrdude: stk500_getsync(): not in sync: resp=0x30

Any tips or troubleshooting I can try?  I know code, I'm just a total n00b to Uno.

ADVthanksANCE
I remember when USENET was social media.  Your argument is invalid.

Coding Badly


Do you only have a a USB cable connected to the Uno?

Where did you buy the Uno?

Is the operating system Windows Vista?  (I assume it is from your reference to "WInVista")

http://arduino.cc/forum/index.php/topic,73748.0.html
...pass or fail?

retrolefty


My Arduino Uno is fresh out of the box.  I've installed (I think) the WinVista drivers successfully.

I'm just working on loading and running blink().  The COM port seems to be recognized,
That is a good sign, and that must be the com port number you select before you can upload to the board. So no show stopper here yet.

but as soon as the board has power, I get some random blinkiness on L1, then it cycles on/off about one cycle/sec.  Same behavior if I press the reboot button.

That is probably normal as most boards ship these days with the blink program already loaded and it will run as soon as the board has power. The first 'random blinkiness' is the bootloader checking to see if the IDE is requesting a new upload and the steady 1 second blink is the blink sketch running. So no show stopper here yet either.

  I get the same error on upload:
avrdude: stk500_getsync(): not in sync: resp=0x30

So did you select the proper COM port and select the proper board type in the tools menu before performing the upload attempt?

Lefty


Any tips or troubleshooting I can try?  I know code, I'm just a total n00b to Uno.

ADVthanksANCE

Go Up