Go Down

Topic: Arduino Uno R3 HS ou pas ? (Read 1 time) previous topic - next topic

skywodd

Bonjour,

Procède par étape :
1 - câble entre Rx et Tx, sans ATMega
-> si ce que tu tapes dans le SerialMonitor te revient en écho c'est que l'ATmega16U2 est ok
-> sinon c'est lui qui pose problème
Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

Ironic62

Cool,

ATMEGA enlevé, shunt entre TX et RX sur la platine Arduino.
Envoi d'un (ou plusieurs) octet via le SerialMonitor.

Résultat :
L'octet revient dans le SerialMonitor et les 2 led (RX et TX) de la platine Arduino clignote 1 fois en même temps.
Si je retire le shunt, l'octet ne revient pas bien sur.

Conséquence :
L'16U2 n'est pas mort, c'est l'ATMEGA qui a lâché.
J'ai déja commandé un ATMEGA, on verra bien.

Merci.



skywodd


Conséquence :
L'16U2 n'est pas mort, c'est l'ATMEGA qui a lâché.
J'ai déja commandé un ATMEGA, on verra bien.

Aurait tu un programmateur d'AVR ou une autre carte arduino de dispo (pour utiliser arduinoISP) ?
Juste histoire de tester si ce ne serait pas le bootloader qui aurait quitté le navire.
Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

Ironic62

Pour le moment j'ai que mon Arduino Uno HS.

Mais j'ai commandé 2 (modèles différents) usb to serial
- CP2102 USB 2.0 to UART TTL 6PIN Module Serial Converter
- USBasp USBISP 3.3V / 5V AVR Programmer USB ATMEGA8 ATMEGA128

Et aussi un Arduino Mini ATMEGA328

J'attends de recevoir mon ATMEGA 328P pour remplacer celui défectueux.
Si c'est bien ca et que mon Arduino fonctionne, je m'en servirais pour reflasher le bootloader de l'autre ATMEGA 328P.


Ironic62

Pour info, c'était bien le ATMEGA 328P qui était HS. Je l'ai remplacé et la carte Arduino refonctionne.
Je n'ai pas encore tenté de reflash le bootloader de ATMEGA 328P supposé HS.

Go Up