Pages: [1]   Go Down
Author Topic: Did I just fry my microcontroller, and how?  (Read 1976 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 46
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi.

I had succeeded in controlling 3 12v solenoids via Max/msp sending serial to the arduino.
I was using 2 9v batteries in series and an irf520 mosfet along with a diode for each switch.

So basically everything went fine until I removed my third solenoid and tried to replace it with another solenoid (exact same type) with much longer wires on it. I wanted to
test if this was possible and if it didn't take too much current.

As soon as I plugged the first wire into my battery positive side, my whole system went down including my macbook rebooting.
When I had it back on, everything appeared to be fine (arduino internal LED's lighting normally), but I couldn't get even my old setup without the long wires to work.
So I tried uploading the sketch again (to see if the data had somehow been erased in the shutdown), but when trying this, the arduino IDE just tells me:

avrdude: stk500_recv(): programmer is not responding

and the usual blinking-when-uploading is not there. So I guess I fried the chip, no?
I have no living idea how this could happen.. I mean, everything worked before and I didn't apply any more voltage to the circuit. Could the resistance of the long wires be enough to kill the circuit somehow? The wires are aprox 2 meters each.

I've attached two pictures of the circuit, and hope it's possible to make some sense out of it.
I could write a schematic if it would be easier.

Basically all I did was to follow the pictures in the bottom of this link http://www.thebox.myzen.co.uk/Tutorial/Power_Supplies.html  and then just doing the same thing 3 times with arduino digital out pins 9, 10 and 11.


Any kind of clue would be very much appreciated. I'm not the biggest electronic-wiz, sorry.

Regards
Søren


* foto.JPG (347.12 KB, 960x720 - viewed 25 times.)

* foto2.JPG (308.55 KB, 960x720 - viewed 18 times.)
Logged

Offline Offline
Full Member
***
Karma: 5
Posts: 181
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

If you added and removed components while the circuitry had power there is a good chance you fried something.  That sort of thing is really not recommended.
Logged

Poole, Dorset, UK
Offline Offline
Edison Member
*
Karma: 52
Posts: 2396
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Check which comms port the arduino is on the reboot may have changed the comms port. I'd unplug the USB restart he IDE and the plug in the USB and try again. (unplug all that other hardware fist).

Mark
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 46
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

@ laadams
auch, I wasn't aware of that! but shouldn't the transistor do so that the power only connects when it's "triggered"? or am I misunderstanding something?

@ holmes
thanks for the tip, but I tried all that - without luck :/
Logged

Manchester (England England)
Offline Offline
Brattain Member
*****
Karma: 639
Posts: 34726
Solder is electric glue
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
As soon as I plugged the first wire into my battery positive side, my whole system went down including my macbook rebooting.
Always connect the ground first.

But it sounds like you had a short circuit somewhere. Often that is OK but it depends on what path is causing the short.
Try the loop back test first. It might be just one of the chips that has gone.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 46
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

@mike

thanks for the tip!
I tried doing a loopback test, but nothing shows up in the serial monitor, and it doesn't seem like it's reseting all the time as it's supposed to. not even if I hold down the reset button. hm..
Logged

Offline Offline
God Member
*****
Karma: 27
Posts: 829
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have done something similar and it turned out that somehow the bootloader was just lost. I erased the chip and relaoded the bootloader and all was fine again. Of course, I had to do this with a programmer since the serial was not working without the bootloader.

Obviously (if you haven't already done this) I would disconnect your circuit and just work on getting the arduino talking again.
Logged

Pages: [1]   Go Up
Jump to: