Pages: [1]   Go Down
Author Topic: Arduino Due&UDN2981A für LED Ansteuerung  (Read 617 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo zusammen,

ich habe leider meinen Arduino Due gehimmelt und finde den Fehler nicht. Ich hoffe Ihr könnt mir einen Typ geben, bzw. vielleicht habe ich irgendwo einen Denkfehler...

Ich habe den aufbau mal schnell in paint gezeichnet da mir gerade kein besseres mittel zur Verfügung steht.

Folgender Aufbau:



Erklärung:
Der Micro (Arduino Due [Vin PIN]), die Bausteine (UDN2981A) und die Last (12 LEDs) werden mit 10V versorgt.

Ziel ist es die LEDs mittels der PWM Ausgänge (2-13) des Due über die Treiberbausteine zu betreiben.

Nun ist mir folgendes passiert:

Ich habe das wie oben erklärt aufgebaut, das Beispiel Programm Blink draufgespielt und mit einer Diode an Port 13 und Mico powered by PC (per USB Kabel) ausprobiert  und es hat ordnungsgemäß funktioniert. Daraufhin wollte ich die Funktion der Treiber/meines Aufbaus testetn und habe den mico an mein Board (mit den Treibern, LEDs und Widerständen) und 10V geschlossen. Daraufhin leutete nichts, ausser die LED auf dem DUe board was an Pin 13 angesclossen ist. Daraufhin habe ich angefangen zu messen und wärend dieses Vorganges ist mir dann aufgefallen das ich keine Spannung mehr an dem Mico messen konnte und die on board LED nicht mehr blinkte. Ich ahnte was passiert war machte Spannung aus fühlte am Micro welcher schon ziemloch heiß war. Nach Anschluss an den PC  bestätigte sich mein Verdacht das der Micro gehimmelt ist.


Da ich aber trotzdem das Porjekt zu Ende bringen möchte (mit einem neuen Due dann...), suche ich den Fehler. Folgende Ideen hierzu habe ich, wobei ich hoffe das ihr mir helfen könnt..

a) Durch Messspitzen 10V auf PIN 13 gegeben was mC kaputt gemacht hat. d.h= Aufbau ok nur Eigendoofheit^^
b) Fehler in Schaltung (Ist der Aufbau richtig? Brauchn die Inputs des Treibers Widerstände`Wenn ja wieso?)
c) Lötfehler (suche ich bereits aktiv nach smiley-grin)


Ich hoffe es kann mir einer helfen, vielen vielen Dank schonmals
« Last Edit: February 18, 2013, 09:01:41 am by Hyga » Logged

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 261
Posts: 21576
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Wo hast Du die 10V am Arduino Du angeschlossen?
Grüße Uwe
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo Uwe,

Beim Arduino an Vin und beim Baustein entspechend des Datenblattes
Logged

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 261
Posts: 21576
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Dann habe ich keine Erklärung wieso der Arduino Due kaputtgegangen ist.
Natürlich ist a) möglich und die Erklärung daß der Arduino UNO nicht mehr am USB gesehen wird könnte das bestätigen.
Ich sehe gerade, daß die unbenutzten Ausgänge des UDN2981 auf Masse gelegt sind das ist falsch. Laß sie frei. Die Eingänge gehören auf Masse aber nicht die Ausgänge. Da würde ein nichtfunktionieren der schaltug erklären aber nicht das heißwerden des µControllers.
b) Ich sehe gerade, daß die unbenutzten Ausgänge des UDN2981 auf Masse gelegt sind. Das ist falsch. Laß sie frei. Die Eingänge gehören auf Masse aber nicht die Ausgänge. Da würde ein Nichtfunktionieren der Schaltug erklären aber, nicht das Heißwerden des µControllers. Ersete auch den UDN. Der könnte kaputtgegangen sein und so die 10V an die Arduino Pins geschickt haben.
Nein, es braucht keine zusätzlichen Widerstände. Der UDN hat sie schon drin
c) Ja, könnte natürlich sein, aber da können wir Dir keine Ferndiagnose durch auflegen der Hand auf den Monitor mit Deinem Tread machen  smiley-wink smiley-wink
Grüße Uwe
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Vielen Dank für die antworten. Also das mit den Ausgängen auf GND werde nachher direkt mal tauschen. Ich werde jetzt einen Duemilanove zum testen nehmen, da dieser mir zum Testen reicht und ich dort bei defect die Microcontrollerbausteine einfach tauschen kann.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Frage zu den ungenutzen Ausgänegen/Eingängen, wieso schadet das dem Contoller wenn ich Output=Input=GND anschliesse? (Habe das so aus dem Datenblatt gelesen)???
Logged

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 261
Posts: 21576
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Frage zu den ungenutzen Ausgänegen/Eingängen, wieso schadet das dem Contoller wenn ich Output=Input=GND anschliesse? (Habe das so aus dem Datenblatt gelesen)???
Weil der A2981 kaputgehen kann und so 10 V über die anderen Eingänge an den Arduino kommen.

Bei unbenutzten Teilen von ICs läßt man immer die Ausgänge frei und die Eingänge legt man auf definierte Pegel (je anche IC Masse oder +5V)

Grüße Uwe
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Vielen Vielen Dank, ich werde das nachher mal ausprobieren (wenn ich meinen Duemillanove gefunden habe :-)) und dann berichten ob es geklappt hat. smiley-mr-green
Logged

Pages: [1]   Go Up
Jump to: