Pages: 1 ... 3 4 [5]   Go Down
Author Topic: DS1307 [RESOLU]  (Read 6099 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 0
Posts: 63
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Me revoilà !! smiley-twist

J'ai une très grande nouvelle!! Mon DS1307 n'est pas foutu et marche!! oui il arrive à me donner l'heure correctement!!

Mais...Oui il y a un MAIS!!! que lorsqu'il est monté sur un breadboard c'est quoi son probléme!! smiley-cry

J'ai racheté un autre ds1307 et lui aussi me fait pareil les deux ne marche que sur la breadboard avec les "MEMES composant". (même pile, même quartz, même résistances)
J'avais même refait un circuit tout neuf pour le nouveau.

Je ne comprend plus rien c'est normale ça?
Logged

France S-O
Offline Offline
Edison Member
*
Karma: 41
Posts: 2173
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Je ne comprend plus rien c'est normal ça?
Non mais si tu faisais le schéma réel et complet: interne à la carte DS07 et liaisons avec l'arduino, cela aiderait pour trouver une explication.

Première vérification à faire : toutes les liaisons masses nécessaires sont-elles effectuées ?
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 63
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ben le schéma n'a pas changé c'est toujours les mêmes branchements j'ai juste refait le même circuit mais sur une breadboard et ça marche nikel.
 


* ds1307.jpeg (13.76 KB, 640x480 - viewed 35 times.)
Logged

France
Offline Offline
Faraday Member
**
Karma: 36
Posts: 3429
There is an Arduino for that
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
les deux ne marchent que sur la breadboard
.....
J'avais même refait un circuit tout neuf pour le nouveau.

De là a en déduire qu'il y a un problème sur ton circuit....
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 63
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
De là a en déduire qu'il y a un problème sur ton circuit....

Mais avec un circuit comme ça y pas 50 façons de ce tromper. La seul chose qui change de la bread ce sont les soudures mais j'ai vérifié et revérifié avec un ohm-mètre toutes les connections sont bonnes. Un truc doit perturber l'oscillation mais là a force d'avoir le nez dedans je ne vois plus rien.


* ds1307ci.jpeg (17.29 KB, 640x480 - viewed 31 times.)
Logged

France
Offline Offline
Faraday Member
**
Karma: 36
Posts: 3429
There is an Arduino for that
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Mais avec un circuit comme ça y pas 50 façons de ce tromper
il faut être pragmatique. Si le composant est bon et que le soft tourne sur la breadboard, il ne reste que ton circuit.

Quote
La seul chose qui change de la bread ce sont les soudures mais j'ai vérifié et revérifié avec un ohm-mètre toutes les connections sont bonnes.
Les connexions sont bonnes OK.
Mais as-tu vérifié s'il n'y avait pas des connexions en trop? Je m'explique, il peut y avoir un petit pont de soudure, une petite paille de cuivre entre 2 broches. L'ohmmètre ne remplacera jamais une inspection visuelle avec une bonne loupe. C'est d'ailleurs une bonne habitude de le faire avant de monter les composants parce que s'il y a un pont sous le boîtier, tu peux chercher longtemps. Et cela arrive souvent même sur ces circuits imprimés réalisés chez des professionnels.
« Last Edit: February 22, 2013, 11:22:53 am by fdufnews » Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 63
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Je suis entrains de m'arracher les cheveux.
Je viens de monter mon ds1307 avec le minimum c.a.d deux résistance de 4k7 et le quartz +les broches pour le connecter et il marche.

Ca viens bien de mon circuit mais alors où???
C'est quand même impressionnant parce que j'ai fait deux circuit qui ne marche pas lol
Enfin qui ont la même erreur et je n'arrive pas à l'identifier.  smiley-lol

fdufnews j'ai bien vérifier même à l'oeil mais rien... je comprend vraiment pas et c'est pas faute d'avoir cherché et recherché.
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 63
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bon ça y est on y est tout marche comme il faut.

Ca venait bien de mes circuits.

Je ne sais toujours pas où est mon erreur mais bon j'en ai refait un 3eme et celui-ci marche donc bon. Comme on dit jamais deux sans trois.

En tout cas merci pour votre aide.
@ bientôt!!!
Logged

France
Offline Offline
Faraday Member
**
Karma: 55
Posts: 5347
Arduino Hacker
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Ca venait bien de mes circuits.

Je ne sais toujours pas où est mon erreur mais bon j'en ai refait un 3eme et celui-ci marche donc bon. Comme on dit jamais deux sans trois.
Peut être un problème de micro-coupure d'une piste ?
Logged

Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

Offline Offline
Faraday Member
**
Karma: 33
Posts: 4964
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bon ça y est on y est tout marche comme il faut.

Ca venait bien de mes circuits.

Je ne sais toujours pas où est mon erreur mais bon j'en ai refait un 3eme et celui-ci marche donc bon. Comme on dit jamais deux sans trois.

En tout cas merci pour votre aide.
@ bientôt!!!
Bonsoir
le principal c'est que finalement ce soit bien tombé en marche  smiley-mr-green
les DS1307 sont quand même des compos "fiables" et pas mal tolerant.

peut être un problème de gravure

Logged

Pages: 1 ... 3 4 [5]   Go Up
Jump to: