Pages: [1] 2   Go Down
Author Topic: problème eclipse-arduino  (Read 2424 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 19
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour,

Je souhaite utiliser eclipse pour l'arduino, cependant, j'ai des soucis lors de l'installation de la librairie arduino. J'ai suivi ce tutoriel : http://www.baeyens.it/eclipse/Install.html ainsi que celui-ci en français: http://shyrobotics.com/tutoriel-2-comment-programmer-une-carte-arduino_20130210.html.

Mon problème est bien évidemment marquer nulle part, c'est pour cela que je fais appel à vous.

Voici un screen des erreurs que j'ai:

En espérant que vous puissiez m'aider
Logged

Offline Offline
Full Member
***
Karma: 1
Posts: 144
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

tiens un copain smiley-wink

alors je vais te faire la réponse qu'on m'a faite : n'utilise pas une librairie qui peut du jour au lendemain disparaitre  lol

je démarre mon eclipse et te dis ce que j'ai fait.
Logged

Offline Offline
Full Member
***
Karma: 1
Posts: 144
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

re

donc j'ai en bookmark ces trois tuto que j'avais gardé et qui m'ont aidé a configurer eclipse :

http://playground.arduino.cc/code/eclipse
http://www.chipkin.com/using-eclipse-with-arduino-duemilanove/
http://www.codeproject.com/Articles/110859/Arduino-Unleashed


quand a ton probleme il est simplement que le serveur est indisponible le moment ou !

bonne chance.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 19
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ah oui là ce n'est plus la solution facile c'est sur... Je te remercie pour l'aide que tu m'as apporter
J'avais déjà essayer de suivre ce tutoriel il y a 6 mois mais j'avais des erreurs lors de la compilation. Cependant je viens de refaire tout le tutoriel et voici l'erreur que j'obtiens:


En vous remerciant d'avance
Logged

IDF/SO
Offline Offline
Edison Member
*
Karma: 41
Posts: 2311
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Pour l'erreur sur pins_arduino.h c'est parce que tu n'a pas importé le fichier qui se trouve sous le répertoire "variants" de l'IDE.
L'autre erreur je ne sais pas.

Pour les tutos j'ai aussi le lien suivant:
http://www.arrizza.com/cgi-bin/pub?ArduinoHowTo
et les sous liens dans le paragraphe "Some common activities"
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 19
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour,

Je suis retourné a ma configuration d'eclipse, après avoir revérifier tout les paramètres entre les différents site que vous m'avez donnés et après avoir inséré pin_arduino.h voici l'erreur que j'ai:



Je voulais savoir si je l'avais bien inséré et au bonne endroit. Sinon, est-ce que cela est normal que d'un site sur l'autre, les configuration ne sont pas les même?

Merci d'avance
Logged

Offline Offline
Full Member
***
Karma: 1
Posts: 144
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

le cpp ?  smiley-wink
Logged

Offline Offline
Full Member
***
Karma: 1
Posts: 144
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

humm
en fait non.

mais tu as fait quoi la ? tu as "copier coller" les librairies de l'arduino ??

tu devrais renseigner tes includes ... plutot que "coller" les librairies dans ton projet, et au pire tu fait un "link" ... 

pour ce que j'en dis smiley-wink
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 19
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Pour le pin_arduino, oui j'ai fait un copié coller

Comment je renseigne mes includes?
Logged

Offline Offline
Full Member
***
Karma: 1
Posts: 144
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

tous les tuto cité ci dessus te dises comment faire :

entre autre :
http://playground.arduino.cc/code/eclipse#Eclipse_Arduino_core_library
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 19
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ah oui d'accord, mais tout ça je l'ai fait...

Sauf que le pin_arduino ne s'insère pas quand je fais toutes ces étapes donc je doit le copié/coller

pour le pin_arduino il me dise bien de le copié non?
Copy the contents of the Arduino IDE's hardware/cores/arduino directory into this "src" folder. If you are using Arduino >1.0, you also need to copy the pins_arduino.h file out of the folder that matches your target under hardware/arduino/variants/.
Logged

Offline Offline
Full Member
***
Karma: 1
Posts: 144
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

donc si c'est fait, si tu ouvres ton dossier "includes", tu vas y trouver tes différents "path" et dedans tu vas y trouvers tous les fichiers que tu as mis manuellement a la racine de ton projet. non ?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 19
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bon j'avance petit à petit, j'ai refais plusieurs fois les configurations avec plusieurs site différents et j'arrive a compiler la librairie sans erreur. Maintenant lors de la compilation du projet, eclipse ne peut pas créer de fichier .elf et je ne sais pas du tout d’où viens le problème. Voir la photo ci-dessous

grâce à ce site, http://www.chipkin.com/using-eclipse-with-arduino-duemilanove/ on peut télécharger le dossier du projet blinky, et je constate que la seul différence que j'ai par rapport à mon fichier est la librairie. Moi je ne l'ai pas malgré que j'ai configurer plusieurs fois de façon différentes.

De plus, lorsque je met le programme dans mon main.cpp, il me dit qu'il connait aucune fonction (voir photo)

Merci de votre aide


* Capture.PNG (58.93 KB, 1362x724 - viewed 43 times.)

* Capture1.PNG (84.38 KB, 1361x726 - viewed 48 times.)
Logged

Offline Offline
Full Member
***
Karma: 1
Posts: 144
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

tu as ton Arduino.h ?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 19
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

oui oui j'ai bien mon arduino.h

ça viendrait de là le problème de la création du .elf?
Logged

Pages: [1] 2   Go Up
Jump to: