Pages: [1] 2   Go Down
Author Topic: Server web, besoin d'aide  (Read 1429 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour
j'ai un probleme pour creer mon serveur web.
J'utilise une Arduino leonardo coupler avec un shield ethernet.
Ensuite je charge le code proposer dans le tuto : http://arduino.cc/en/Tutorial/WebServer
je compile, charge sans aucun  problème.
Ensuite dans mon navigateur web je tape l'adresse 192.168.1.177 et la ... rien....

j'ai loupé un truc? ou j'ai pas compris quelque chose?
mon but pour commencer et simple, afficher une page web simple dans un premier temps puis ensuite, pouvoir commander une led via la page web créé.

cela fait quelques jours que je tourne en rond et test du code a plus savoir qu'en faire...
si quelqu'un pouvait me dire ou je me suis planter.

d'avance merci pour votre aide
Logged

Ile-de-France (92 sud), France
Offline Offline
Edison Member
*
Karma: 24
Posts: 2055
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Que disent les Serial.print() dans le moniteur série ?
Logged

Barbuduino: Arduino sur Breadboard & VinciDuino: Clone Leonardo // WR703: Mini-routeur hacké // LauchPad MSP430 et Stellaris // Panda II Arduino-like .NetMF sous VisualC#
RTFC: Read That F.....g Code / RTFD: Read That F.....g Doc / RTFDS: Read That F.....g DataSheet / RTFS: Read That F.....g Schematic / Wot da ya wanna D.I.Y. today ?

0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Merci pour la reponse rapide
alors les serial print (dans la fentre pour espinner la com serie) j'ai : "server is at 192.168.1.177" et rien d'autre
si cela peux aider, j'ai relié mon arduino directement sur a mon pc sur l'ethernet (et j'ai aussi le wifi activer pour surfer mais meme non connecté ca marche pas..)
Logged

france
Offline Offline
God Member
*****
Karma: 15
Posts: 866
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Le shield ethernet ne passe pas par le wifi mais par un câble Ethernet rj45,  à brancher sur sa livebox (en plus du câble usb entre arduino et pc)
Logged

Christian

Offline Offline
Sr. Member
****
Karma: 2
Posts: 259
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Encore que tu pourrais essayer de changer ton cordon droit par un cordon croisé. Sinon, branche ton montage sur la box.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

j'avais pas penser au cable croiser ... je vais faire un essai de suite
par contre je peux le mettre sur ma box ok mais je ne sais pas encore du tous comment la configurer...

je reviens vers vous pour le test du cable croiser
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

he... cable croisé mis et non pas mieux....
une idée?
Logged

Offline Offline
Edison Member
*
Karma: 17
Posts: 1951
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

bonjour,
type de modem?
c'est bien sur la bonne plage ip?
peux tu pingger l'ip?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

bonjour
type de modem==> j'ai une sfr box (mais comme dit plus haut je suis en direct sur la carte reseau pour l'arduino)
c'est bien sur la bonne plage ip==> yes ( du coup ce soir je fais un essai en me mettant derriere la box)
peux tu pingger l'ip? non j'ai cela quand je ping:


Envoi d'une requête 'Ping'  192.168.1.81 avec 32 octets de données :
Réponse de 192.168.1.81 : octets=32 temps<1ms TTL=128
Réponse de 192.168.1.81 : octets=32 temps<1ms TTL=128
Réponse de 192.168.1.81 : octets=32 temps<1ms TTL=128
Réponse de 192.168.1.81 : octets=32 temps<1ms TTL=128

Statistiques Ping pour 192.168.1.81:
    Paquets : envoyés = 4, reçus = 4, perdus = 0 (perte 0%),
Durée approximative des boucles en millisecondes :
    Minimum = 0ms, Maximum = 0ms, Moyenne = 0ms

merci pour votre aide
Logged

France
Offline Offline
Faraday Member
**
Karma: 38
Posts: 3509
There is an Arduino for that
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Envoi d'une requête 'Ping'  192.168.1.81 avec 32 octets de données :

tu nous a dit que l'IP de ton arduino était 192.168.1.177
Logged

Offline Offline
Edison Member
*
Karma: 17
Posts: 1951
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Envoi d'une requête 'Ping'  192.168.1.81 avec 32 octets de données :

tu nous a dit que l'IP de ton arduino était 192.168.1.177

héhé  smiley-mr-green
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

A oui c'est vrai.. j'ai mis le mauvais ping hier soir   smiley-eek-blue...
(c'est ca de faire plein de test  smiley-twist)....
Je remet le rapport officiel ce soir (mais quand je ping en 177 il me repond sur le 81 de memoire. C'est pour cela que j'ai testé le 81)
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Alors voici le ping :

C:\Users\Fana>PING 192.168.1.177

Envoi d'une requête 'Ping'  192.168.1.177 avec 32 octets de données :
Réponse de 192.168.1.81 : Impossible de joindre l'hôte de destination.
Réponse de 192.168.1.81 : Impossible de joindre l'hôte de destination.
Réponse de 192.168.1.81 : Impossible de joindre l'hôte de destination.
Réponse de 192.168.1.81 : Impossible de joindre l'hôte de destination.

Statistiques Ping pour 192.168.1.177:
    Paquets : envoyés = 4, reçus = 4, perdus = 0 (perte 0%),

Et toujours pas moyen de le faire marcher meme derrière ma box

J'ai toujours besoin d'aide ....je commence a deseperer  smiley-cry smiley-cry
Logged

Offline Offline
Edison Member
*
Karma: 17
Posts: 1951
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

je pense que l'ip 177 n'est pas prise en compte et que le modem réattribut une autre ip derrière.
remplace le 177 par ton 81 pour voir.
et fixe l'ip dans le modem pour sa mac.
Logged

Biganos
Offline Offline
Sr. Member
****
Karma: 2
Posts: 362
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

salut

Ta box est-elle en mode routeur ?

A+
Logged

ORDINAUSORE 2Ghz AMD64 QUI S'ALLUME EN 48 SECONDES AVEC UBUNTU 12.04
ARDUINO UNO / Shield Ethernet / RTC DS1307
Programmation Python et j'apprends le C
Technicien Télé Vidéo à la retraite.

Pages: [1] 2   Go Up
Jump to: