Pages: [1] 2   Go Down
Author Topic: How to use Arduino 1.5.2 on Debian Wheezy 64bit?  (Read 3525 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 1
Posts: 66
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I am using Arduino 1.5.2,
Debian 3.2.35-2 x86_64 GNU/Linux,
Linux 3.2.0-4-rt-amd64 #1 SMP PREEMPT RT.

I try to test my sketches on the DUE and get the following error.
   It would be nice if the IDE would allow to cut&paste it somehow smiley-wink   so typing...

Code:
Cannot run program /home/dada/arduino-1.5.2/hardware/tools/g++_arm_none-eabi-g++:java.ioException: error=2, No such file [...]

~/arduino-1.5.2/hardware/tools/g++_arm_none_eabi/  is a directory btw,
but i suspect the IDE might show a truncated path smiley-sad

Google tells me that this is a 32/64bit libraries issue, but I couldn't find out yet
what packages to install on my Debian/Wheezy system to make it work.

Can somebody tell me?
Logged

Offline Offline
Jr. Member
**
Karma: 1
Posts: 66
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I am *still* not able to compile on Arduino 1.5.2 using Debian/Squeeze 64bit,
so still cannot test my code on the DUE...

For a quick test I would also be interested if there is a Linux live CD known to run with Arduino 1.5.x
to compile and upload programs for the DUE.

Advice very much appreciated.
Logged

Forum Administrator
Milano, Italy
Offline Offline
Sr. Member
*****
Karma: 23
Posts: 292
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Code:
Cannot run program /home/dada/arduino-1.5.2/hardware/tools/g++_arm_none-eabi-g++:java.ioException: error=2, No such file [...]

It seems that you can't run the compiler, this is probably due to wrong permissions.
How did you unpack the arduino distribution file?

I suggest you to use tar from command line:

Code:
tar xfvz arduino-1.5.2-linux64.tgz
Logged

C.

Offline Offline
Jr. Member
**
Karma: 1
Posts: 66
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

It seems that you can't run the compiler, this is probably due to wrong permissions.

Yes, as mentioned in the original post the files look strange:

Code:
dada@i5:~$ ls -Al ~/arduino-1.5.2/hardware/tools/g++_arm_none-eabi-g++
ls: cannot access /home/dada/arduino-1.5.2/hardware/tools/g++_arm_none-eabi-g++: No such file or directory

dada@i5:~$ ls -Al ~/arduino-1.5.2/hardware/tools/
total 2888
-rwxr-xr-x 1 dada dada    248 Feb  6 13:37 adk2install
-rwxr-xr-x 1 dada dada  11899 Feb  6 13:37 adk2tool
drwxr-xr-x 6 dada dada   4096 Feb 23  2012 avr
-rwxr-xr-x 1 dada dada 960618 Feb  6 13:37 avrdude
-rw-r--r-- 1 dada dada 960618 Feb  6 13:37 avrdude64
-rw-r--r-- 1 dada dada 550213 Feb  6 13:37 avrdude.conf
-rwxr-xr-x 1 dada dada 388904 Feb  6 13:37 bossac
-rwxr-xr-x 1 dada dada  58216 Feb  6 13:37 bossac64
drwxr-xr-x 6 dada dada   4096 Sep  6  2010 g++_arm_none_eabi  # <<< directory with *similar* name...
-rw-r--r-- 1 dada dada      0 Feb  6 13:37 .keep
-rw-r--r-- 1 dada dada    950 Feb 23  2012 readme.txt

dada@i5:~$ ls -Al ~/arduino-1.5.2/hardware/tools/g++_arm_none_eabi/
total 540
drwxr-xr-x 5 dada dada   4096 Sep  6  2010 arm-none-eabi
drwxr-xr-x 2 dada dada   4096 Sep  6  2010 bin
-rw-r--r-- 1 dada dada 528755 Sep  6  2010 getting-started-2010q1.pdf
drwxr-xr-x 3 dada dada   4096 Apr 17  2010 lib
drwxr-xr-x 3 dada dada   4096 Sep  6  2010 libexec
-rw-r--r-- 1 dada dada   1132 Sep  6  2010 README

I *did* use tar from a text terminal, btw smiley-wink

Thanks for replying.
Logged

Forum Administrator
Milano, Italy
Offline Offline
Sr. Member
*****
Karma: 23
Posts: 292
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

mmmhhh, I see, that's weird

is the arduino-1.5.2 installation clean?
have you some 3rd party "hardware" folder in your sketchbook? May, in case, temporarily rename it, and retry?
Which version of Java have you installed?

C
Logged

C.

Offline Offline
Jr. Member
**
Karma: 1
Posts: 66
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

mmmhhh, I see, that's weird

is the arduino-1.5.2 installation clean?

I have 'rm -rf' it, downloaded it again and 'tar -xzf' and repeated the test.
Opening the IDE gave me more of the path this time, but same error.

Sorry to say, but I *hate* GUIs that do not let me c&paste such lengthy error messages...

No, no ~/sketchbook/hardware/ folder.

Don't know about Java version,
Will tell you after figuring out how to know...
Logged

Offline Offline
Jr. Member
**
Karma: 1
Posts: 66
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Running the GUI from a terminal window it says:
Java lib Version   = RXTX-2.1-7

Does this answer the question about Java version?
Logged

Forum Administrator
Milano, Italy
Offline Offline
Sr. Member
*****
Karma: 23
Posts: 292
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

mmmhh nope, but try to run the IDE from a terminal, launch a compile, and see what is printed on the terminal.. maybe we can gather some more informations....
Logged

C.

Offline Offline
Jr. Member
**
Karma: 1
Posts: 66
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

try to run the IDE from a terminal, launch a compile, and see what is printed on the terminal..
maybe we can gather some more informations....

Always did it like this, but unfortunately no, no more information.

The error message is only visible in the GUI on an orange banner between source and the black error message window, not even shown there. I also cannot cat&paste it from the "banner" which I don't like...

The IDE 1.5.2 works well with a mega, upload had sync problems on a Duemilanove that has always worked well with older versions.
Logged

Forum Administrator
Milano, Italy
Offline Offline
Sr. Member
*****
Karma: 23
Posts: 292
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


I forgot to ask: have you enabled verbose compile and upload from the preferences dialog?
Enabling it should give you much more output on the terminal.
Logged

C.

Offline Offline
Jr. Member
**
Karma: 1
Posts: 66
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

@cmaglie   Please excuse the long answer time, was mostly away from computers a few days.

I forgot to ask: have you enabled verbose compile and upload [...]

Oh, I should have thought about this, sorry. Had tried shift compile, at least.

Code:
~$ ./arduino-1.5.2/arduino
Experimental:  JNI_OnLoad called.
Stable Library
=========================================
Native lib Version = RXTX-2.1-7
Java lib Version   = RXTX-2.1-7
/home/dada/arduino-1.5.2/hardware/tools/g++_arm_none_eabi/bin/arm-none-eabi-g++ -c -g -Os -w -ffunction-sections -fdata-sections -nostdlib --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf -mcpu=cortex-m3 -DF_CPU=84000000L -DARDUINO=152 -D__SAM3X8E__ -mthumb -DUSB_PID=0x003e -DUSB_VID=0x2341 -DUSBCON -I/home/dada/arduino-1.5.2/hardware/arduino/sam/system/libsam -I/home/dada/arduino-1.5.2/hardware/arduino/sam/system/CMSIS/CMSIS/Include/ -I/home/dada/arduino-1.5.2/hardware/arduino/sam/system/CMSIS/Device/ATMEL/ -I/home/dada/arduino-1.5.2/hardware/arduino/sam/cores/arduino -I/home/dada/arduino-1.5.2/hardware/arduino/sam/variants/arduino_due_x -I/home/dada/sketchbook/libraries/Menu /tmp/build5390247795744229471.tmp/softboard.cpp -o /tmp/build5390247795744229471.tmp/softboard.cpp.o

Code:
$ ls -l /home/dada/arduino-1.5.2/hardware/tools/g++_arm_none_eabi/bin/arm-none-eabi-g++
-rwxr-xr-x 2 dada dada 208112 Apr 17  2010 /home/dada/arduino-1.5.2/hardware/tools/g++_arm_none_eabi/bin/arm-none-eabi-g++
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello,

I had exactly the same problem on my 64bits Gentoo because ARM compiler binaries are for 32bits hosts (see http://arduino.cc/forum/index.php/topic,142531.msg1070305.html#msg1070305).

A possible solution could be to install necessary 32bits system libraries (libc-32bits, ...) to resolve dependencies.

You can search all 32-bits executables using this:
Code:
file $(find arduino-1.5.2/hardware/tools/g++_arm_none_eabi/) | grep "ELF 32-bit LSB executable, Intel 80386"
then use the command "ldd" to identify the dependencies to install.




Logged

Forum Administrator
Milano, Italy
Offline Offline
Sr. Member
*****
Karma: 23
Posts: 292
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


A possible solution could be to install necessary 32bits system libraries (libc-32bits, ...) to resolve dependencies.

@JerryBz, thanks! you made me remember this thread:

http://arduino.cc/forum/index.php/topic,130901.msg1105567.html#msg1105567

probably installing the "ia32-libs" debian package may solve the problem.
@OutOfLine, please confirm if this fix works for you.
Logged

C.

Russia
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I've fix same issue on my Ubuntu Studio 12.10 64bit by installing only two packets:
Code:
sudo apt-get install libc6:i386
sudo apt-get install libstdc++6:i386
Blink example successfully compiled and uploaded.
I don't like to install ia32libs package since it take some major change in system - apt-get tells about 227Mb updates and 5 packets will removed...   
Hope it helps.
Logged

Offline Offline
Jr. Member
**
Karma: 1
Posts: 66
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

probably installing the "ia32-libs" debian package may solve the problem.
@OutOfLine, please confirm if this fix works for you.

unfortunately no, aptitude leaves me in dependency hell
might be my system

i plan to do another Debian Wheezy install on another system soon, will try there again.

thanks for you help.
Logged

Pages: [1] 2   Go Up
Jump to: