Pages: [1] 2   Go Down
Author Topic: Teensy 2.0 Teensy Loader Error  (Read 1615 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 26
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm having a really confusing time right now.

I've never had any problems with the loader, in fact I've been using it for my Teensy++ 2.0 for months.
I plugged in the 2.0's I bought a week ago and now the loader doesn't work for either. Below is a video with this behavior.
http://www.youtube.com/watch?v=TeqohEXw2_o&feature=youtu.be

The IDE compiles for the Teensy 2.0, but I have to rummage through my temp folder to find the compiled hex manually with the loader.

To try and make sure it wasn't just the Arduino install, I now have 1.03, 1.53, and 1.02 (my original install) and I've installed the Teensyduino package on all of them.

Any ideas would be greatly appreciated.
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 200
Posts: 12779
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


Where did you buy them?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 26
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

PJRC
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 200
Posts: 12779
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


Did you install Teensyduino after each of the Arduino IDE versions?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 26
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I said so in my first post.
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 200
Posts: 12779
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


Do you have access to an "older" Teensy (one of the Teensy boards that you know works)?  Does it still work correctly?
« Last Edit: February 22, 2013, 04:29:03 pm by Coding Badly » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 26
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

It's not a problem with the boards, it's a problem with the software. The boards work perfectly, the cable works perfectly, the drivers are installed and are working properly. The HalfKey works perfectly (on the 2.0, the 2.0++ doesn't function like this).

The video in my first post shows what happens:
1) it compiles
2) creates a file in my temp directory
3) opens the Teensy Loader program (if it isn't open already)
4) error shows that asks if the loader is open

I can:
1) Program every board I have
2) Compile for every board
3) Load any program I have

I recently reset my router and reconfigured it. This is the only thing I did before this all happened.
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 200
Posts: 12779
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


Operating system?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 26
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Win7 Pro x86 on laptop w/ Core2Duo 2GB RAM, using Windows Firewall.
I unzipped the Arduino software, installed Teensyduino on the versions I have.
If you want to look at my config files lemme know which ones to post.
« Last Edit: February 22, 2013, 11:17:09 pm by transcendtient » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 26
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Here is the verbose output of the loader.
22:29:56: Verbose Info event
22:30:24: remote connection opened
22:30:25: remote connection opened
22:30:25: remote connection opened
22:30:26: remote connection opened
22:30:26: remote connection opened
22:30:26: remote connection opened
22:30:27: remote connection opened
22:30:27: remote connection opened
22:30:27: remote connection opened
22:30:28: remote connection opened
22:30:28: remote connection opened
22:30:28: remote connection opened
22:30:29: remote connection opened
22:30:29: remote connection opened
22:30:29: remote connection opened
22:30:30: remote connection opened
22:30:30: remote connection opened
22:30:31: remote connection opened
22:30:31: remote connection opened
22:30:31: remote connection opened
22:30:32: remote connection opened
22:30:32: remote connection closed
22:30:32: remote connection closed
22:30:32: remote connection closed
22:30:32: remote connection closed
22:30:32: remote connection closed
22:30:32: remote connection closed
22:30:32: remote connection closed
22:30:32: remote connection closed
22:30:32: remote connection closed
22:30:32: remote connection closed
22:30:32: remote connection closed
22:30:32: remote connection closed
22:30:32: remote connection closed
22:30:32: remote connection closed
22:30:32: remote connection closed
22:30:32: remote connection closed
22:30:32: remote connection closed
22:30:32: remote connection closed
22:30:32: remote connection closed
22:30:32: remote connection closed
22:30:32: remote connection closed

So it opens crap tons of connections for some reason.
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 200
Posts: 12779
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


I have: Teensy 2.0 in an unopened package; Windows 7 64b; Ardiuno 1.0.3; Teensyduino downloaded and installed last night.

I open the package and connect the Teensy.  The onboard LED blinks. 

I click the reset button on the Teensy.  The operating system installs the driver for it.

I start the Arduino IDE, enter an empty sketch, and click verify.  After a successful build the Teensy Loader starts.

I click upload.  The Teensy resets and the new sketch is successfully uploaded.

I suspect the problem is either a background application on your computer interfering with the Loader or the last sketch you uploaded interfering with the upload process.
Logged

Offline Offline
Sr. Member
****
Karma: 7
Posts: 275
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Perhaps you want to post your problems on the forum dedicated to the teensy boards:

http://forum.pjrc.com/forum.php
Logged


Offline Offline
Newbie
*
Karma: 0
Posts: 26
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

It is not a problem with the boards, it's the software.
It can't be the last sketch I uploaded doing this, I ALREADY SAID I'VE UPLOADED A BUNCH OF DIFFERENT SKETCHES.
If it could be a background application, and you have any idea of how that could be possible, let me know.

I know I'm asking you guys for help here, but seriously if you have anything I can TRY to do, please let me know.

I've posted my problem on the PJRC forums, they have alot less traffic than this forum does, and I don't honestly know if it's a problem on the Arduino side, or the Teensy side, so I'm looking in both places.
Logged

Dallas, TX USA
Offline Offline
Faraday Member
**
Karma: 63
Posts: 2650
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I've seen this happen before.
Did you try pressing the button on the Teensy?

It is possible that the current application
code on the teensy board is not alive enough to talk to the loader.
Pressing the button is a reset to a bootloader that can talk to the teensy loader program.
This allows the download to happen and should straighten things out again.
But if the code is crashing or locking up, you may have to use the button again.

--- bill
« Last Edit: February 25, 2013, 12:20:36 am by bperrybap » Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 200
Posts: 12779
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


Try this...

• Navigate to the Teensy Loader.  It should be in the {Arduino IDE Root}\hardware\tools directory.

• Run it as administrator (right-click teensy.exe then click Run as administrator)

• Navigate to the arduino.exe.  It should be in the {Arduino IDE Root} directory.

• Run it as administrator (right-click arduino.exe then click Run as administrator)

• Try to upload
Logged

Pages: [1] 2   Go Up
Jump to: