Go Down

Topic: Noise on Due Dac (Read 1 time) previous topic - next topic

bglsmith

Reads on an SD card can be heard through the Dac.

Arduino Due
AdaFruit Micro-SD Breakout Board (Board -> SPI and Pin 10)
AdaFruit MAX98306 Amplifier (Board -> DAC0, GND, 3.3V)

Things I've tried to get rid of the noise.
1.  Redid wiring using Jameco connectors -> still noise.
2.  Bypass Amplifier to externally amplified speakers -> still noise.
3.  Tried Dac0 and Dac1 -> noise on both.

I've attached a picture of the wiring.

Any help is greatly appreciated.

pito

#1
Feb 23, 2013, 01:06 pm Last Edit: Feb 23, 2013, 01:17 pm by pito Reason: 1
That could be caused by grounding loops. Try to connect each module's GND wire to a good decoupled "single ground point" ("star" topology). Maybe a decoupling of each module's power (small resistor in series and capacitor to gnd) could help as well.

stimmer

How are you powering the board? I had extreme noise on a Bluetooth A2DP module connected to a Due, which turned out to be caused by powering the board by USB. When powered by a 9v battery into the DC jack the noise disappeared.
Due VGA library - http://arduino.cc/forum/index.php/topic,150517.0.html

bglsmith

I've tried powering the board using both the USB and a 9V battery and using a star topology for ground, but the noise is still present.  I haven't tried decoupling each module's power yet, but I'll try that next.

lencinhaus

Hi bglsmith, any progress on this? I'm having the exact same problem an I've still had no luck getting rid of the ground noise. I didn't try decoupling though, did it work for you? Any help would be greatly appreciated, thanks

bglsmith

I couldn't figure out how to get rid of the noise, so I found a product from RuggedCircuits called RuggedAudio that I use.  http://www.ruggedcircuits.com/html/rugged_audio_shield.html

This shield wasn't specifically designed for the Due, so to use it I
* cut traces 13, 12, 11
* solder in the SPI header on the card
* remove the card to flash the Due

I use a SanDisk SD card.
I scale the audio to 12 bit

http://forum.audacityteam.org/viewtopic.php?f=26&t=36498#p96024 (instructions to do this in audacity are in one of the posts)

Because of the 12 bit audio there is some static noise, but this solution has been acceptable for me.

garygid

Are you saying that the DAC produces a noisy analog voltage,
incorrectly representing the digital data that it is converting?

Possibly test this by running a 1KHz perfect square wave data
into the DAC, and put a scope on the output, if possible?

Or, that the output of an amplifer, into speakers, has some
unexpected noise,even though the DAC output looks "clean"?
Cheers, Gary
Due for controlling Electric car charging.
Nissan LEAF - Mini Quick Charge (mQC)

Go Up