Pages: [1]   Go Down
Author Topic: [solved]simple question, am i about to fry my components (led voltage)  (Read 748 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hi, bit new at this,
simple question

i have this 7 segment display
http://www.datasheetcatalog.com/datasheets_pdf/T/O/S/5/TOS5121AS.shtml

its got a common cathode.
i'd liek to drive it with my arduino eleven clone through a shift register (74hc595). which is currently light 7 seperate led's (which i want to replace with this 7 segment display)
but the data sheet says forward voltage is 3v and i think the arduino runs off 5v
will it work? i'm using some 470ohm resistors to help add a bit of resistance.

thanks,
« Last Edit: February 23, 2013, 06:58:58 pm by magnets » Logged

Offline Offline
Edison Member
*
Karma: 58
Posts: 2078
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

You should use a resistor for every segment. If I google for it, I see that 470 Ohm is used most of the times.
Scroll down on this page for a similar schematic, http://arduino.cc/forum/index.php?topic=20201.15
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

thanks, will do, and the voltage will be ok even though it says 3v on the data sheet?
Logged

Offline Offline
Edison Member
*
Karma: 58
Posts: 2078
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

They need a certain current, and the resistor reduces the current.
Just don't apply a voltage to them, and you are fine.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

yay, plugged it in, all good.
i used a 470ohm resister to each segment.
I'm not sure what you mean about not applying a voltage to them. I have to apply a voltage to create a high or low signal. Or in other terms, to have electricity 'flow' through a circuit i need voltage don't i?
sorry if im' not making myself clear. its been a long while since i did basic electronics at school smiley-mad)
Logged

Offline Offline
Edison Member
*
Karma: 58
Posts: 2078
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

If you apply a voltage with unlimited current, the leds of the 7 segment display will get overheated very quickly if the voltage is too high.
If you apply a current, there a a voltage over the leds. But that voltage can be called a 'voltage drop'.

Use any led you have, and try a few things. If you connect a led to a 5V power supply without resistor, you might see a flash or not. But the led is broken. If the voltage is too low, the led doesn't do anything. Connect the led with a resistor to 5V and it is okay. Perhaps you should wear safety glasses.
Logged

Global Moderator
Offline Offline
Brattain Member
*****
Karma: 480
Posts: 18729
Lua rocks!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

but the data sheet says forward voltage is 3v and i think the arduino runs off 5v
will it work? i'm using some 470ohm resistors to help add a bit of resistance.

http://led.linear1.org/1led.wiz

You enter your source voltage (5V) your forward voltage (3V) and the number of milliamps (from the datasheet) and it gives you a resistor value.

From that page, 470 ohms would give you a current of 5 mA.
Logged


Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ah!
right that makes sense.
thanks very much
Logged

Pages: [1]   Go Up
Jump to: