Go Down

Topic: AVRdude problem [solved] (Read 1 time) previous topic - next topic


Feb 24, 2013, 07:21 am Last Edit: Feb 26, 2013, 07:30 am by Nick Gammon Reason: 1
Here is the verbose output, cut to meet the 9500 character limit. Any ideas on a fix?

Code: [Select]

avrdude: Version 5.11, compiled on Sep  2 2011 at 18:52:52
        Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
        Copyright (c) 2007-2009 Joerg Wunsch

        System wide configuration file is "/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf"
        User configuration file is "/Users/aurelius/.avrduderc"
        User configuration file does not exist or is not a regular file, skipping

        Using Port                    : /dev/tty.usbmodemfd16311
        Using Programmer              : arduino
        Overriding Baud Rate          : 115200
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

avrdude done.  Thank you.

Coding Badly

You have the wrong serial port or board selected.


Right board selection, and I'm pretty sure that is the right serial port.

I tried the loop-back test by connecting Rx and Tx with a jumper and setting the reset pin to ground. Nothing is echoed in terminal window.

Coding Badly

If the board uses an ATmega processor for USB-to-serial conversion you could try reflashing the processor.


Hmmm. Not really sure how to do that. Pressing reset on the board flashes the LED at L. If I try and upload any sketch, it hangs and the LED stays on. Not sure if that is helpful

Coding Badly

Feb 24, 2013, 09:24 am Last Edit: Feb 24, 2013, 11:38 pm by Coding Badly Reason: 1
Not really sure how to do that.

I don't know how to do that either because you haven't indicated which board you are trying to use.



Feb 24, 2013, 11:44 pm Last Edit: Feb 24, 2013, 11:47 pm by spatula Reason: 1
Someone with the same setting solved the problem using a powered USB switch*. See http://arduino.cc/forum/index.php/topic,149500.msg1125561.html (please provide feedback if it works for you as well).

[edit] *I meant USB hub.

Coding Badly

The board uses either an ATmega16U2 or an ATmega8U2 for USB-to-serial conversion.

The processor supports "dfu" mode for reprogramming.  You may be able to restore the processor using that mode.  This should get you started...

If that doesn't work, you can use an "ISP" programmer (another Arduino compatible board will work) to try to restore the processor.  This should get you started...

I have not done it myself so that will very likely be the only guidance I can provide.


Spatula, I'm already plugged into a powered usb hub.


Coding Badly,

I uploaded the ArduinoISP sketch to a Mega2560, connected the appropriate pins (10-13, 5v,gnd) to the ICSP header on the Uno. Attempting to burn a bootloader with the board set to the Mega and Programmer with Arduino as ISP returns the same error. The yellow "L" LED stays lit on the uno until I reset it.

Coding Badly

Burn bootloader doesn't work for the USB-to-serial processor.  You will have to use avrdude from the command-line.  The images are in this directory...

[font=Courier New]{Arduino IDE Root}\hardware\arduino\firmwares\atmegaxxu2\[/font]

Make certain you are using the correct ISP header.  The one closest to the USB connector is the correct choice.


And I feel like an Idiot. I was using the wrong sketch to upload. I need the Standalone AVR ISP programmer sketch from Adafruit, not the ArduinoISP sketch in the example folder. All seems to be well. Thanks everybody for trying to help me out.

Go Up