Go Down

Topic: Q about .ino files not linking/opening the IDE in Win 7 64 (Read 673 times) previous topic - next topic

BlackLab1

Feb 24, 2013, 11:36 pm Last Edit: Feb 24, 2013, 11:41 pm by BlackLab1 Reason: 1
I am having a problem with linking .ino files with the Arduino IDE 1.0.3. under windows 7 -64. The files work fine inside of the IDE {they will open/close/save and will open with drag and drop}. But will not open by double clicking on them with the Arduino IDE, like a word doc or PDF file opens with the correct program.

I have the check box in the preferences box to update sketch files to new extension on save, but double clicking on the .ino file to launch the IDE does not happen. I have gone so far as to right click on the .ino file and did a <Open With> then try to use the <Other Program> but the Arduino IDE does not show up there. So next step I <Browse> inside of the <Open With> window to the correct directory where Arduino.exe is located and click on the Arduino program but Window refuses to link any of the .ino files to the Ardunio.exe program.

I even went looking for the answer in "Microsoft Windows 7 unleashed" by Paul McFedries- but their example "Working with File Types" ~page 48-60 does not quite enlighten on how to get the two parts together.

Right now, without forcing the file to open inside of the IDE, or doing a drag and drop an ino file on to the IDE, the two programs associated with .ino files are Adobe acrobat 9.4 and Photoshop CS4 in the <Open With> window. But neither program shows up under the regedit- HKEY_CLASSES_ROOT .ino extensions inside of the Registry. I am not even finding any connection with .ino and Photoshop or acrobat 9.4 under HKEY_CLASSES_ROOT\Applications in the Registry either. So I am lost as to how those two programs got tied to .ino files.

My goal is just to be able to double click on any of my .ino files and have them launch the Arduino IDE with the .ino file ready to work on. {Note all are in the correct directory to have the IDE launch them- if that helps.}
Any Ideas how to correct this?

el_supremo

I have Win 7 Pro 64-bit and the file association works just fine.
When you use Browse to select Arduino.exe you must click on Apply. If you click on OK, it doesn't change the file association.

Pete

Go Up