Go Down

Topic: Problems with loading code onto Leonardo (Read 493 times) previous topic - next topic

Sh4kE

Hi Guys,

I'm having problems loading any code onto an Arduino Leonardo.

I always get this error:
Code: [Select]
Found programmer: Id = "-18
-1"; type =

    Software Version = -.1; Hardware Version = 7.
avrdude: error: buffered memory access not supported. Maybe it isn't
a butterfly/AVR109 but a AVR910 device?


I'm using the linux 64-binary version from the official page. I also tried using the official ubuntu version (I'm running ubuntu 64-bit 12.10), but the problem still gets up.  Do you have any clue about what that means? Or does anyone else have these problems on ubuntu 64?



Sh4kE

Hmm, same problems under arch linux. Maybe the leonardo is damaged somehow? Because loading code to an uno works like a charm.

Erdin

Remove the Arduino IDE from the repositories, and download the Arduino 1.0.3.
Unpack it and run it from that folder.

Go Up