Go Down

Topic: [SOLVED] Removing a library from the IDE (Read 6695 times) previous topic - next topic


Feb 27, 2013, 12:31 pm Last Edit: Feb 28, 2013, 07:20 am by Patouf Reason: 1
Hi, I would like to know how to remove a library that was added with the " add library". I tried to remove the files from the folder (even deleting the folder) but I still have the library name in the menu, and when I click on it nothing is included (because I deleted the files).


If think that is fixed if you close down the IDE and restart. I guess of you have already found that out, you know I am right....


Nope, this doesn't work... by the way, maybe I should have tell that I use Arduino 1.5.2. Not the 1.0.3


Nope, this doesn't work... by the way, maybe I should have tell that I use Arduino 1.5.2. Not the 1.0.3

Since "Add library" is part of the 1.5 development, it was already clear you weren't using 1.0.3.

The 1.5x branch is considered beta and this is one of the features being worked on.  So it is possible "remove library" isn't implemented yet or has a bug.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com


I found were was my problem. I didn't noticed that all libraries are copied in the sketchbook folder. I removed it from there and it worked. :)


"Imagination is more important than knowledge."


Thanks for reading,

The problem I face is related  to   Arduino  + UBUNTU

How to remove  a contributed Library map   in UBUNTU ??

Firsts i did make an Arduino  project  in W7  it worked okay after some trial and error.
But suddenly W7 lost its capability to upload  it just fails with  USB-comport error.
I already had to change to a second PC  w7-64 failed with Arduino W7-32 did work for a while

Therefore I decided  to switch to UBUNTU
UBUNTU is fine and easy  with USB
 select Arduino Uno on/dev/ttyACM0
and upload works as it should work.

But  now I faile to compile an sketch that should be okay to compile.
// Include the library code
#include <LiquidCrystal.h>           font color  orange
#include "rotary.h"                       font color blue
#include <EEPROM.h>               font color orange

following error:
AD9850_LCD_ROTARY_WMENUS.ino:8:20: fatal error: rotary.h: No such file or directory
compilation terminated.

it should be solved  with simple adding rotary.h  to the library

 but that i can't   it is very difficult!
An empty folder rotary is blocking the import of rotary.zip
i can not find the IDE library  location  in UBUNTU to delete it

if it was in Windows7 I could  but   
Must I use another name like rotary1  to be able to install?  that seems a bit primitive to me
was a delete function forgotten?

The W7 version 1.6.5   has the modify library function but my version in Ubuntu is installed as 1: 1.0.5
and can only ad library in zip form   
to find  rotary.zip  and download is also not easy
All sites i hit upon are  full of information about the technical details of rotary encoding  but simply a down loadable  rotary.zip   to use  is hard to find.


Go Up