Go Down

Topic: Linux: Running bossac command run by arduino IDE fails on comand line (Read 1 time) previous topic - next topic

Jantje

Hi
I'm working on my arduino Eclipse plugin and thanks to the Arduino team I recently own a Due.
I tried to upload a sketch to the due but failed with my plugin. So I made a sketch in the Arduino IDE 1.5.2 which uploaded fine with the following command
Code: [Select]
/home/jan/programs/arduino-1.5.2/hardware/tools/bossac --port=ttyACM0 -U false -e -w -v -b /tmp/build772742258670103613.tmp/sketch_feb27a.cpp.bin -R

When I run this command on the command line it fails with a error with does not really help to understand the problem.
Code: [Select]
bash-4.1$ /home/jan/programs/arduino-1.5.2/hardware/tools/bossac --port=ttyACM0 -U false -e -w -v -b /tmp/build772742258670103613.tmp/sketch_feb27a.cpp.bin -R
Flash for chip ID 6374656b is not supported
bash-4.1$

Anyone can help me out?
Best regards
Jantje
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

stimmer

stty -F /dev/ttyACM0 1200

That triggers the flash erase and starts the samba bootloader.

Set it back to 9600 or 115200 or whatever to reset the Arduino and get the program running.
Due VGA library - http://arduino.cc/forum/index.php/topic,150517.0.html

Jantje

stimmer
Thanks for the answer.
I tried this command and indeed it worked.
Code: [Select]
stty -F /dev/ttyACM0 1200;/home/jan/programs/arduino-1.5.2/hardware/tools/bossac --port=ttyACM0 -U false -e -w -v -b /tmp/build772742258670103613.tmp/sketch_feb27a.cpp.bin -R;stty -F /dev/ttyACM0 115200

I need to think how I will handle this in my plugin.
Best regards
Jantje
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

Go Up