Go Down

Topic: Probably making a stupid mistake, but need someone to point it out to me (Read 2050 times) previous topic - next topic

centizen

Hey there everyone, I'm trying to set up a 3x3 grid of multicolored LED's that have two sets of jumper banks that I want to use to be able to change the color of each LED. I'm not interested in changing the design unless it's inherent to my issue, so please nobody recommend charlieplexing it. However, I am seeing a strange behaviour out of the board I have made which follows this schematic:



The LED I am using is a knockoff Cree common anode RGB LED.

Basically, I set up my jumpers like this to make five of the LED's go red and four of the LED's go blue.



However, none of my blue lights turn on, only the red ones. But, if I take all of the jumpers out of the red bank, then all of the blue lights will turn on. As soon as even one jumper is bridging the the red grounds, none of the blue grounds will work. Any idea's why this might be?

Thanks

Michael

KeithRB

Where are teh current limiting resistors? Are you accounting for the difference in forward voltage between the different colors of LED's?

retrolefty

You should first work from a schematic drawing including voltage source, to proof the design before jumping to a layout picture. A link to yourLED type might be helpful also.

I make little sense of your work, but maybe I'm just having a bad hair day.

centizen


Where are teh current limiting resistors? Are you accounting for the difference in forward voltage between the different colors of LED's?


Built in, and no, I have no idea what that means. Care to elaborate?

This is the LED I'm using

http://www.adafruit.com/products/314

retrolefty



Where are teh current limiting resistors? Are you accounting for the difference in forward voltage between the different colors of LED's?


Built in, and no, I have no idea what that means. Care to elaborate?

This is the LED I'm using

http://www.adafruit.com/products/314


What makes you believe there are current limiting resistors built into the LEDs? I see no evidance of that in the datasheet. http://www.adafruit.com/datasheets/BL-FL7680RGB.pdf

Lefty

centizen

In my experience, without a current limiting resistor, LED's simply burn out in a couple of seconds. I was under the impression that these ones didn't burn out when I applied 3.3v because they had a built in resistor to the LED. I can't remember who I heard that from, but looking back it's not too plausible. That being said, I'm not sure if that is what is causing the issue because I can run all 9 LED's at full brightness no problem on red but as soon as I throw one blue in the mix, it won't work.

retrolefty


In my experience, without a current limiting resistor, LED's simply burn out in a couple of seconds. I was under the impression that these ones didn't burn out when I applied 3.3v because they had a built in resistor to the LED. I can't remember who I heard that from, but looking back it's not too plausible.


Well live and learn. Leds almost always require external current control. So unless you find a datasheet that explicitly shows some form of internal current control then it's on your design to provide it. You don't power leds with voltage, you control the amount of current that is allowed to flow through them.

Lefty

centizen

So you think that the reason this isn't working is because I'm missing current flow control? i'll try building another one tomorrow with resistors on it if that is the case.

retrolefty


So you think that the reason this isn't working is because I'm missing current flow control? i'll try building another one tomorrow with resistors on it if that is the case.


Without a proper schematic drawing I'm not prepared to say why it isn't working. However I will say that those led do require external current control.

Lefty

SirNickity

I have some LEDs like these that I got from the Digikey.  They are a bit temperamental in terms of how they're biased.  I think your problem is that the blue and red cathodes aren't entirely isolated from each other.  The datasheet doesn't actually give pin information (annoying, and annoyingly common for RGB LEDs...) so it's possible you're not even using the right pin as the anode.  Any way to verify you've wired them right?

centizen

I know I've got the wiring right on that board for each respective LED. But that makes a lot of sense actually. Are there any good RGB LED's that you know of that won't have this bias issue?

afremont

Since you don't have any current limiting, then the power supply and circuit wiring is doing it for you; otherwise the LEDs would have burnt right out.  The forward voltage drop (Vf) of the red LEDs is less than that of the blue ones.  Since you effectively have them in parallel the voltage is too low to turn the blue ones on once a red one is plugged in.  Take a volt meter and see what your power supply voltage measures at the circuit board, I bet it doesn't measure what you expect when the LEDs are on.
Experience, it's what you get when you were expecting something else.

SirNickity

I know I've got the wiring right on that board for each respective LED. But that makes a lot of sense actually. Are there any good RGB LED's that you know of that won't have this bias issue?

No I don't actually.  I haven't used many.  I'm always surprised that they don't work like three single LEDs sharing the same plastic.  For e.g., both RGB LEDs I have on hand refuse to light up multiple colors at the same time.  You *have to* PWM between the R, G, and B legs sequentially if you want to do any color mixing.

oric_dan

Quote
However, none of my blue lights turn on, only the red ones.

Despite the assumptions, despite what the datasheet may or may not be appearing
to say, the only way to make any sense out of this whole thing is to take a single
Led in hand, and play with it until you get the pin connections straightened out.

A lot of DMMs have a diode test position, and it would take 30 seconds to figure the
whole thing out.

Then, I would take 5V and a 1K resistor and see how the Leds glowed.

Then, if I truly believed they had built-in Rs, I would take exactly one Led with the
intent that I might be sacrificing it to the gods of thermodynamics, and apply full
voltage to it, and see if it glowed for an instant and then forever flamed out.

ONLY THEN would I hook up the original ckt shown. Better than blowing up $18 worth
of Leds at square one.

Lastly, if I were really really desparate, I might go read where adafruit mentions
something about "three legs to ground through a resistor".
http://www.adafruit.com/products/314




Grumpy_Mike


I know I've got the wiring right on that board for each respective LED. But that makes a lot of sense actually. Are there any good RGB LED's that you know of that won't have this bias issue?

No I don't actually.  I haven't used many.  I'm always surprised that they don't work like three single LEDs sharing the same plastic.  For e.g., both RGB LEDs I have on hand refuse to light up multiple colors at the same time.  You *have to* PWM between the R, G, and B legs sequentially if you want to do any color mixing.

That sounds like you are only using one resistor per LED.

Looking forward to the OP's schematic being posted on this one.

Go Up