Go Down

Topic: LCD + SD Shield and Breakout Board SD Not working (Read 1 time) previous topic - next topic


Hello all, I've had problems using the SD part of my LCD attachment. My setup is a Mega 2560, a TFT LCD Mega Shield v1.2, and a 3.2" Touch Screen LCD. I already had a thread about it here: http://arduino.cc/forum/index.php/topic,127972.msg962427.html#msg962427 I decided to take time off of it to work on another project, and now decided to pickup where I left off. (sorry for the long post)

Just trying to use the SD Card Info sketch (modified for the mega, and my shield)
Code: [Select]
Initializing SD card...initialization failed. Things to check:
* is a card is inserted?
* Is your wiring correct?
* did you change the chipSelect pin to match your shield or module?

Through some research I discovered that apparently alot of the TFT LCD Mega Shield's were incorrectly designed. So after following the instructions here http://www.sainsmart.com/vanilla/discussion/41/fixed-v1-0-version-of-sainsmart-tft-lcd-adjustable-shield-for-arduino-mega-2560/p1 Now it will at least initialize the card but then it says:
Code: [Select]

Initializing SD card...Wiring is correct and a card is present.

Card type: SD2
Could not find FAT16/FAT32 partition.
Make sure you've formatted the card

If I remove the LCD Breakout board (not the shield, just the breakout) and attach a separate SD breakout board (The one mentioned in the previous thread) using jumper wires, with the same SD card, formatted the same way it works fine:
Code: [Select]
Initializing SD card...Wiring is correct and a card is present.

Card type: SD2

Volume type is FAT32

Volume size (bytes): 1971351552
Volume size (Kbytes): 1925148
Volume size (Mbytes): 1880

Files found on the card (name, date and size in bytes):
PIC302.RAW    2011-01-29 02:40:18 153600
PIC303.RAW    2011-01-29 02:40:28 153600
PIC304.RAW    2011-01-29 02:40:38 153600
PIC305.RAW    2011-01-29 02:40:50 153600
PIC306.RAW    2011-01-29 02:41:00 153600
PIC307.RAW    2011-01-29 02:41:10 153600
PIC308.RAW    2011-01-29 02:41:20 153600
PIC309.RAW    2011-01-29 02:41:30 153600
PIC310.RAW    2011-01-29 02:41:38 153600
TEST1.BMP     2012-10-17 09:36:12 77878
TEST2.BMP     2012-10-17 09:36:26 77878
TEST3.BMP     2012-10-17 09:36:38 77878
TEST4.BMP     2012-10-17 09:36:48 77878
TEST5.BMP     2012-10-17 09:37:04 77878
TEST6.BMP     2012-10-17 09:37:16 77878
TEST7.BMP     2012-10-17 09:37:26 77878
TEST8.BMP     2012-10-17 09:37:38 77878
TEST9.BMP     2012-10-17 09:37:54 77878
FILE.DAT      2012-10-17 11:27:58 49
PIC301.RAW    2011-01-29 02:40:08 153600

Does anybody know what the issue may be?
The LCD breakout is connected as shown below(all resistors are 10k) the numbers are (Shield Pin Number - Arduino Pin number)

Thanks -Brad


I  was the same problem wish the PCB board  adapter " TFT LCD Mega Shield V1.2" = clone of
Saintsmart V1.0.  All 2 are a  cross connection D51 & D52, but the I/O level adapter  wish Resistors are not exactly  the same. In all case, the signal noise & signal shape are not good wish resistor adapter.
It is necessary to replace the resistor level adapter wish a chip like 74HC4050 (HEX logic level converter )
Or in my case by 2 pieces  I2C level adapter ref.: http://www.aliexpress.com/item/10pcs-lot-IIC-I2C-level-conversion-module-5V-to-3V-System-Compatible-Module-Dedicated-Free-Shipping/605453615.html
Now is perfect wish standard arduino lib. SD.
Best regards

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131