Go Down

Topic: LED project help (Read 1 time) previous topic - next topic

cshannon

I am trying to do a LED installation that is not working.

I have two color faders, each powered by its own 300W power supply and arduino. From the power supply and Arduino each color is connected by about 20 feet of 12AWG stranded cable and Cat5 for the pwm to power 45 feet of RGB LED strip. This is happening twice, i.e., I am running this cable from the power supplies and arduino in the center of the room to each side. Each color on each side is using IRF510 MOSFETs to drive the common anode LEDs.

When I run just one color to both sides, or when I run two colors to one side, everything is fine. But when I run two colors to two sides the LEDs flicker erratically and are overall dimmer. Does anyone have ideas? I would be surprised if it was a problem with voltage drop since I have two power supplies.

Thanks for any help.

Grumpy_Mike

Quote
I am trying to do a LED installation that is not working.

Looks like you have succeeded. You are trying to make something that does not work and it doesn't, well done.

Your problem is supply decoupling or rather lack of it.

cshannon

"Looks like you have succeeded. You are trying to make something that does not work and it doesn't, well done."
Yes, well I'm good at my job.

Thanks for the idea, I didn't even think of caps. Nearer to the MOSFETs I assume, right? Any guesses on the value?

Grumpy_Mike

Quote
Any guesses on the value?

I would guess a 0.1uF ceramic for the high frequencies in parallel with a 100 to 470uF for the low.


Quote
Nearer to the MOSFETs I assume

Across the supply close to the LEDs

Headroom

The 20feet of CAT5 cable for the PWM would worry me a bit was well. I would expect some signal degradation particularly if the PWM is running at higher fequencies.

Go Up