Go Down

Topic: Trying to flash ATMega16U2 of Arduino UNO R3, using Atmel AVRISP MKII (Read 3758 times) previous topic - next topic


Mar 01, 2013, 08:12 pm Last Edit: Mar 01, 2013, 08:18 pm by GolezTrol Reason: 1
When I try to upload a sketch, I get the error:

avrdude: stk500_getsync(): not in sync: resp=0x00

- It did work before.
- Using Arduino UNO R3 with ATMega328P-PU.
- Previously uploaded sketch still works.
- Other ATMega328P-PU chip with pre-loaded sketch also works in this Arduino.
- Arduino is recognised by PC.
- Trying to upload returns the error quoted above.
- Using Windows 7.
- Using Arduino 1.0.2 IDE.
- Trying to get to DFU mode by temporarily connecting GND and Reset on the connector near the USB port doesn't work. The Arduino stays in its 'normal' mode. Although I must admit that I wouldn't really know what to do next if it would have worked.

I learned that my ATMega16U2 chip might be broken, but maybe it could work again if I upload the firmware again to it.
I do have an AVRISP MKII, and I do have a second Arduino as well, so I want to attempt to do this.

Now I can't find out exactly how to use either device to attempt to revive my first Arduino. I've been searching quite a while, but I can't find any tutorials that explain this, except some global hints. Since I'm relatively new to this stuff, I'm afraid to plug in the MKII the wrong way and damage my Arduino even further.


joining your request I too have a malfunction 16u2 both uno r3 and mega r3 boards
for the moment I just use usbasp for uploading sketches but it would be nice to just use the usb interface again :)
so if anyone would describe in details how to fix the 16u2 that would be great


Yeah, I use an Atmel AVRISP MKII to upload sketches.

I first installed MKII drivers for Arduino. I had to Download them, because I'm using Windows 7 64 bit.
After that, you can Shift+Upload (Upload using programmer) in the Arduino IDE.

Unfortunately, this causes me to no longer use Atmel Studio to upload stuff to other microcontrollers, which I plan to do in the future too, but at least I can use the Arduino now. Direct uploading would be more convenient, though. :)


It could be that the atmega16u2 is ok, but the uno has no bootloader anymore:
After that, you can Shift+Upload (Upload using programmer) in the Arduino IDE.

This erases the bootloader. Could it be that uploading stopped working after you tried this for the first time?
If so, try to burn a bootloader to the uno using the avrisp mkII.

Go Up